0

Recently I bought Dead Island but it seems like Dead Island would give you a black screen. So I went to the console and run ./DeadIslandGame from~/.steam/steam/steamapps/common/Dead Island`. This is what it gave me:

./DeadIslandGame: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No such file or directory

A bit of investigation revealed that there are libSDL2 libraries both in /usr/lib/x86_64-linux-gnu/ (since I tried to do sudo apt install libSDL2*) and also in .steam/ubuntu12_32/steam-runtime.old/i386/usr/lib/i386-linux-gnu/.

My question is how can I make Dead Island run since I'm guessing the problem here is that DI is missing its libraries. However I'm not quite sure.

2 Answers 2

1

You don't need to do anything special. Running games from within Steam runs them with the libraries provided by the Steam client.

However, when you run things manually on the CLI in this manner, the environment is not set up to use the Steam Runtime. The reason you got the missing library error, is because you don't have the i386 version of the libraries installed, but you are attempting to run a 32-bit program.

0

For starters you will need to issue this

sudo dpkg --add-architecture i386

to enable 32 bit libraries to get installed ... then try a re-install of DI to pickup missing libs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.