1

I had 12.04. Recently I upgraded it to 14.04. Before upgrade I made a full hdd copy to very same hdd model(both bought at the same time). In 12.04 wake on lan works if I do sudo pm-hibernate or if I in UI from desktop select "Shutdown".

I upgraded a full HDD copy of 12.04 to 14.04. Use same hardware and wake on lan doesn't work. If I do same steps.

I tried sudo ethtool -s enp2s0 wol g (enp2s0 is a network interface name), but it was previously in g. So no effect.

I have a fresh installation of 16.04.1 and I was able to wake it only once after I set NETDOWN=no in /etc/default/halt, but it did not work after I wanted to verify it once again.

Added at the end of /etc/network/interfaces next 6 lines

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto enp2s0
iface enp2s0 inet static
        address 192.168.0.12
        netmask 255.255.255.0
        gateway 192.168.0.1
        up ethtool s enp2s0 wol g

And did sudo pm-hibernate and was not able to wake up. Only once it worked when I logged in and in UI locally clicked shutdown. After that tried few times and no luck.

1 Answer 1

3

Please note I already had wakeonlan enabled in the bios and through ethtool. It stopped working at some point for me after doing dist-upgrades.

I was able to get it to work for 17.04 by:

1) Installing the tlp package with:

sudo apt-get install tlp

2) Changing the line in "/etc/default/tlp" that says

WOL_DISABLE=Y

To

WOL_DISABLE=N

3) After shutting down the computer it was able to be started with WOL. I test this on two different machines and it worked on both.


After running this solution for a while, I found an unintended side effect where some of my USB devices were losing power. I ended up disabling the USB autosuspend feature of tlp by changing the line in "/etc/default/tlp" that says

USB_AUTOSUSPEND=1

To

USB_AUTOSUSPEND=0
1
  • Sorry for delayed response. Many thanks, for your answer. It really helped me and now it works in 16.04 May 21, 2017 at 2:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.