Does anybody know if the Lenovo IdeaPad V570-1066AJU Laptop is Ubuntu compatible?

It has terrific specs (i5, 6GB, 750GB hd, HDMI and good-looking screen) for the 600$ price, but I want to make sure it will be OK with the latest Ubuntu version.


EDIT (December 24th): I've bought it and managed to get by. See my own answer below.

enter image description here


I am currently running Ubuntu 11.10 on my IdeaPad V570. (Posting from it, actually) A dual boot with Windows 7 installed as my secondary OS. The only issues I'm aware of at this time are that I cannot use my fingerprint reader This is not really an issue, since it has been proven time and time again that the use of fingerprint readers actually adds an unnecessary security hole. Look it up if you don't believe me.

The other problem is that when resuming from sleep the screen remains dark (aka, no backlight). I can still log in, but until I do, the backlight remains off and the fn(up) combination does nothing. Once authenticated everything works as it should.

I highly recommend this laptop as an Ubuntu Linux machine. 4.5 stars (-1/2 for backlight/resume issue)


I can confirm that the memory card reader works in 11.10. I have a MicroSD/Adapter combo plugged in right now with pictures from my camera loaded.

Edit #2:

I can't exactly recall, but I may have had to manually install Grub2 from a livecd. It's not hard to do, just involves a little remounting, chroot, and apt-get. Again, I cannot confirm that I had to do this for this laptop, but I have had to do it recently. If you have trouble booting after a fresh install, queue up your LiveCD and look for a Grub2 installation tutorial.

Edit #3:

The wireless did not work properly right off the bat, but none of the fixes I found worked. I plugged in to my wired connection to make sure my system has been updated to the latest fixes and the WiFi card has been champ ever since.

Final words of wisdom:

If something isn't working, run your update manager. If there is a new version of the OS, Kernel, Software, whatever, download it, update, and reboot. If your stuff still doesn't work after updating, post a bug report.

I don't know how many times I've hammered at a problem for hours or even days to find that it's been fixed with a patch or update that had already been released.

Save yourself the headache and update first.

EDIT #4:

Okay, not as final as I thought... I just reinstalled Ubuntu X86_64 userland/kernel over PXE when I realized I was running a 32 bit userland in my last installation. Wireless does not fix with updates, you need to open /etc/modprobe.d/blacklist.conf and add an entry to block the Acer Wireless module.

Open a terminal and:

    gksudo gedit /etc/modprobe.d/blacklist.conf

Add this line to the bottom:

    blacklist acer_wmi

Step one, Save
Step two, Reboot
Step three...
Step four, World Domination

Nathanael out.


I'm running 64 bit 12.04 on a Lenovo V570 -- everything works out of the box, even the wireless, EXCEPT for the screen remaining off when resuming from suspend. Found the fix : adding "acpi_backlight=vendor" as a kernel boot parameter.

How to temporarily add a boot parameter : https://help.ubuntu.com/community/Grub2#Editing_the_GRUB_2_Menu_During_Boot

How to permanently add a boot parameter : https://help.ubuntu.com/community/Grub2#Configuring_GRUB_2


It might be informative to mention that Ideapad Z580 models experience an ACPI issue and have 10-15 minute boot times currently. I sincerely hope you don't experience a similar issue with the new kernels on your V570! I'm using 3.2.0-32 on my Ideapad with no issue but newer kernels have the issue for me.


Throughout my experience, Lenovo seems to be the most trustworthy linux laptop

Although it is not on certified hardware list on Ubuntu, the hardware doesn't look problematic at all, as the main problems occur on graphic and ethernet/wireless cards.

The link you provided, says that this Lenovo has Intel HD Graphics 3000 card, which is pretty common and quite well supported.

With a little effort of google'ing, we can see that Ubuntu gives the acer-vmi(as usual) kernel module for wireless, though there's a fix here

Also, it looks like that SD card reader seems to be not working (although this might be fixed for 11.10), yet this thread explains how to fix this problem.


FYI, GRUB2 (Ubuntu bootloader) seems to have difficulties with this laptop. Here is a Boot-Repair's log created with this PC showing that GRUB shows no error when installing but the MBR remains with no bootloader. The user reports that after Ubuntu installation, the PC continues to boot straight to Windows (this is normal because Ubuntu 11.10 didn't install GRUB correctly). http://paste.ubuntu.com/779724/


It took some time to install Linux on this computer - definitely not for the faint of heart.

  • grub does not install properly. I've reported this, see details at Bug #908203. The only way I managed to solve this was to install Linux Mint instead of Ubuntu; it got the grub on and now I can add any OS I want.
  • The wireless isn't working properly; this answer hit the spot and solved the problem.
  • What about the touchscreen? – NoBugs Oct 7 '13 at 4:59

Just installed onto my v570 from the CD and had no problems with Grub. Must have been fixed but still had to blacklist the acer wifi as mentioned above to get wifi working. I also have the problem with screen going dark after closing and opening the lid.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.