1

My Ubuntu laptop's wifi keeps disconnecting. It does it what seems to be randomly but frequently after periods of inactivity, though it does it when using the internet etc as well. I have to keep selecting the wifi network (I have the wifi network dialog box open permanently for this purpose). When this happens there will be period where it won't stay connected - it's like a click fest, where I select my network, it ticks it then it disconnects & unticks - repeat & rinse for about 30 seconds until it stays connected !!!!!! Really get on my nerves. Ran the network wireless info tool as shown here

Here is the results when connected Connected Wifi Results

When disconnected the same tool gives the follow error (no internet obv so doesn't work) -

https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info
Resolving github.com (github.com)... failed: Temporary failure in name resolution.
wget: unable to resolve host address ‘github.com’

Any ideas ??? Presuming a driver issue.

  • What's your Wireless card? Don't tell me broadcom – Lynob Nov 12 '16 at 14:48
  • Hi - sorry how do I find that info ? Is it on the wireless info file ? – marginwalker Nov 12 '16 at 14:50
  • askubuntu.com/questions/333424/… – Lynob Nov 12 '16 at 14:51
  • Think it is a Broadcom - BCM4313 802.11bgn Wireless Network Adapter – marginwalker Nov 12 '16 at 14:55
  • try following the answer, if it doesn't work notify me – Lynob Nov 12 '16 at 15:02
3

We see that there are two wireless networks with the same name: SKY7D544. I am quite confident that most of the reason for the disconnects is that your wireless device is roaming between them, always searching for a better connection.

If these are routers over which you have administration priveleges, I suggest that you rename one or both; something like SKY7D544A and SKY7D544B. Then ask your wireless to connect to the strongest of the two and I'm confident it will stay and not disconnect.

If you are unable to rename them, I suggest you ask Network Manager to bind to the stronger of the two like this: Ubuntu connect drops. Worked for a while then started dropping again

  • Thanks for the input. Where did you see two neworks called SKYD544 ? I only see one in my network list, but that could be my issue ! I had a look at the link you provide but can't find my MAC address as the command says scanning isn't supported in my interface. – marginwalker Nov 12 '16 at 16:21
  • Here is a snip from your wireless info: paste.ubuntu.com/23466476 In the wireless info script, the MAC address is redacted. You will need to scan yourself to see it. sudo iwlist wlp7s0 scan – chili555 Nov 12 '16 at 16:24
  • Right I have done a scan & copied the MAC address of what I think is the strongest signal & bound it to the BSSID. Let's see it works ! Thanks for all your help – marginwalker Nov 12 '16 at 16:45
  • Didn't work but I did work out what the other signal was on the same SSID - it's my Wifi booster upstairs !!! This problem existed before I had this booster so I know it's not that. It was a good shout tho' – marginwalker Nov 16 '16 at 21:15
1

I have been having the same problem with Ubuntu 16.04 with Broadcom card.

The only thing which worked for me was installing WICD, a bit irritating that Network Manager can't cope but there you are.

I just installed it from the software centre but alternatively you could use:

sudo apt-get install wicd

Hope it helps you.

  • Cheers will give that a go ! The info above didn't work ! Still kept dying. – marginwalker Nov 16 '16 at 21:13
  • Tried installing WICD, which for a day seemed to work but last night the wifi disappeared ... totally !! I had no visibility of any network. Well it could see my network but it said it was out of range !!!!! The only was to get any connection is to restart the computer. Have uninstalled WICD but still getting this issue. Can't "system restore" in Ubuntu eh ? Don't know how to take it back to prior mucking around other than reinstall of unbuntu. Oh shit..... – marginwalker Nov 19 '16 at 17:30
  • At my wits end with this. I've got to reboot every time the internet goes down (BTW I know the wifi is working as I can access my NAS drive but not the internet !) Do you think if I bought a USB Wifi adapter it would solve this ? How do you disable the internal wifi adapter ? Don't know where the device manager is in Ubuntu !!! – marginwalker Nov 26 '16 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.