I know that this has been asked quite a bit thus far, but I can't find any solutions in the previous posts!

Having installed Ubuntu server 11.10 and SSH, I think I've installed NX Server Free, as I just could not get FreeNX to work. The trouble is that I now get the following error messages when I try and connect with the client;

Xsession: unable to launch "gnome-session" X session --- "gnome-session" not 
found; falling back to default session.

Xsession: unable to start X session --- no "/home/james/.xsession" file, no 
"/home/james/.Xsession" file, no session managers, no window managers, and no 
terminal emulators found; aborting.

Trouble is, NX Server Free isn't really going to work in the long run for me as I need more than two connections at once, so I really need FreeNX. Any ideas?

  • Have you gnome-session-bin installed? What is the error FreeNX gives? – enzotib Dec 3 '11 at 14:48

Thanks for the info, you did put me on the resolution of this incident.

So if you intend to run NX on a Linux distro which does not rely on standard gnome windows manager (gdm) such as Ubuntu from 11.X or such as myself a Mint Maya 13 (mdm for Mate desktop interface), you need to edit the NX node config file /usr/NX/etc/node.cfg and replace the type of default session launched when remotely login with Gnome type of session (which is specified at the client level when creating your connection script).

The problem I had came from the fact that by default, mdm is incompatible with gdm as they share objects. It is the same with Ubuntu session manager, I encountered the same problem before migrating to Mint.

I tried to instal gnome-core as suggested above, but it did not proceed as gdm install crashed (because it shares objects with mdm, same problem with Ubuntu BTW). So I ended up putting the following line in /usr/NX/etc/node.cfg :

CommandStartGnome = "/etc/X11/Xsession mate-session"

instead of the standard

CommandStartGnome = "/etc/X11/Xsession gnome-session"

And now I can login with NX on my Mint Maya with my mdm desktop. Perfect!!

It must be the same with Ubuntu distro Windows manager (I don't know its name)

Don't foget that this is only valid if you select in your NX client a session type Unix / Gnome. You may also be able to select a Unix / Custom and put the startup line pointing toward the default session of your distro. I should give it a try.

Good luck!!


I ran into this issue. NX is launching the Xsession by itself, not with your user. Checkout the following file:


At the bottom of this file you can change what it uses to initiate a Xsession.

Specify path and name of the command to start the GNOME session.

CommandStartGnome = "/etc/X11/Xsession gnome-session"

Specify path and name of the command to start the KDE session.

CommandStartKDE = "/etc/X11/Xsession startkde"

From your question, and without further information, it looks as if you do not have a graphical environment installed at all. NX needs a complete graphical environment, both X.org and GNOME / KDE / another DM.

Verify that you have a working GNOME installation. If your machine uses the Unity desktop, I suppose that some programs that NX will look for when starting a GNOME session will be missing (GDM, gnome-session, nautilus...). In that case, try to install gnome-core which should give you what you need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.