0

How can I fix the sublime-text error below:

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done

Error:

E: The package sublime-text needs to be reinstalled, but I can't find an archive for it.

I get the same error even I tried to remove it:

$ sudo apt-get remove sublime-text
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package sublime-text needs to be reinstalled, but I can't find an archive for it.

Any ideas?

2
  • 1
    Try to do sudo apt-get purge sublime-text. Then do sudo apt-get autoremove Nov 12, 2016 at 9:08
  • @GautamVashisht thanks for the comment. Got it fixed at last!
    – Run
    Nov 13, 2016 at 20:00

1 Answer 1

0

To get rid of this error, type the following commands(one-by-one) in your terminal :-

sudo apt-get purge sublime-text

sudo apt-get autoremove

sudo apt-get update

After that sudo apt-get upgrade will work fine and will not show errors.

To install Sublime Text, download its .deb package for Ubuntu/Debian from here. Then install Sublime Text from that .deb package either using dpkg or GDebi Package Installer(recommended).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .