I just configured Ubuntu Core on my Raspberry Pi 3 and now it is now asking for a user name and password in the terminal (I think). It says:

Ubuntu Core 16 on <my ip address> (ttyl)
localhost login:

I'm not sure whether these fields are for your Ubuntu account username and password or email and password or whatever. I've tried my Ubuntu account username and password and I also tried it with my email and password. Neither worked so I tried leaving them blank which also didn't work.

Is there some default password or did I put it in earlier and if so when or where? If I knew that I might be able to remember what I put.

  • 1
    The username needs to be the one specified in your SSO account (the initial setup printed it out), and the password is not the Ubuntu One password but the password to unlock the SSH key uploaded to your SSO account. The login is now protected via those SSH keys, not by a password.
    – kyrofa
    Nov 21, 2016 at 19:37
  • Take a look at step 4 here : use "ubuntu" for the username and the password Jul 9, 2019 at 11:12

7 Answers 7


Ubuntu Core 16 does not come with a default user name and password. Ubuntu Core requires you to setup a Ubuntu SSO account with your SSH keys, which enable you access to your device. Once in, you can create your own user. Please find the relevant instructions here.


Had the same issue at first.

If you are on a windows machine trying to use putty follow the directions here:


  • 1
    Can you please elaborate on your Answer? Posting a URL without any instructions is not ideal. A short Step by Step would be great :) Nov 22, 2016 at 3:42

If your public key is correctly installed in Ubuntu Core device, when you try login, it not prompt password (with your private key in .ssh directory). So, it prompts password, your device has not correctly installed your public key. Review the account in ubuntu.com, probally you paste the content of file of your public key in your account incorrecly

I needed four tries to login, and a lot of time to understand.

It would bi it very useful be able to upload the key.pub file


If someone still don't know how to login to Ubuntu Core 16 for the first time, here is my solution:

  1. Open PuTTY and load the session that will connect to your Raspberry Pi 3

step 1

  1. Select Auth node on the left panel and Browse to the ssh private key, then hit Open button step 2

After that, it will ask you for login and passphrase for your private key (if you set passphrase when generate ssh key)

  • This doesn't really answer the question being asked. Keep in mind that your solution requires Windows to work, and this is not a Windows support site. OP hasn't said anything about whether Windows is at play here or not, and OP isn't even talking about remote access/SSH.
    – Thomas Ward
    Apr 18, 2018 at 14:01
  • Sorry, my bad. I thought that it's stakoverflow. Should I delete my answer?
    – nxt
    Apr 19, 2018 at 9:33

You should have added your public ssh key into your Ubuntu SSO account at this page

Logging in requires that your ssh client has the private ssh key. There should be no password required

More details are present in the docs

  • Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) Dec 23, 2016 at 15:31

I solved the same issue by:

  • First, generate a private and public key on your PC.

ssh-keygen -t rsa -C example -b 2048

  • Second, copy and save the generated public key (file.pub) on the UbuntuOne portal.
  • Third, Try to login to the device using the SSH with the private key on your pc

ssh -i id_rsa username@xx.xx.xx.xx


Check that you're typing your username exactly as it should be (including case), by comparing it to the output of whoami run in a terminal.

Probably the keyboard layouts configuration is wrong fo the tty (which is a different setting than Xorg / Unity) and your password is wrong because of this.

Make sure you're typing the correct password by first typing it in the login field where you can see if it's being written as expected.

If the keymap is the case then try to rebuild it with command:

sudo dpkg-reconfigure console-setup

And reboot before the next try.

Not the answer you're looking for? Browse other questions tagged or ask your own question.