1

Following previous post How to install pgAdmin 4 in desktop mode on Ubuntu 16.04, I had an error (can't find Python.h). Also someone mentioned about changing to python3, how would I go by doing this?

Thanks in advance.

pip install pgadmin4-1.1-py2-none-any.whl

Processing ./pgadmin4-1.1-py2-none-any.whl

Requirement already satisfied: Flask-Principal==0.4.0 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: blinker==1.3 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: unittest2==1.1.0 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: testscenarios==0.5.0 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: extras==0.0.3 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: Jinja2==2.7.3 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: importlib==1.0.3 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: traceback2==1.4.0 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: Flask-WTF==0.12 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: pytz==2014.10 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: sqlparse==0.1.19 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: python-dateutil==2.5.0 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: six==1.9.0 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: passlib==1.6.2 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: pyrsistent==0.11.13 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: Flask==0.11.1 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: ordereddict in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: WTForms==2.0.2 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: Flask-Mail==0.9.1 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: Werkzeug==0.9.6 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: linecache2==1.0.0 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: SQLAlchemy==1.0.14 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Collecting psycopg2==2.6.2 (from pgadmin4==1.1)
  Using cached psycopg2-2.6.2.tar.gz
Requirement already satisfied: python-mimeparse==1.5.1 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Collecting html5lib==1.0b3 (from pgadmin4==1.1)
Requirement already satisfied: MarkupSafe==0.23 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: click==6.6 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Collecting speaklater==1.3 (from pgadmin4==1.1)
Collecting Flask-Security==1.7.5 (from pgadmin4==1.1)
Collecting simplejson==3.6.5 (from pgadmin4==1.1)
Collecting Babel==1.3 (from pgadmin4==1.1)
Requirement already satisfied: testtools==2.0.0 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Collecting pycrypto==2.6.1 (from pgadmin4==1.1)
  Using cached pycrypto-2.6.1.tar.gz
Collecting Flask-SQLAlchemy==2.1 (from pgadmin4==1.1)
Requirement already satisfied: pbr==1.9.1 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Collecting Flask-Gravatar==0.4.2 (from pgadmin4==1.1)
  Using cached Flask_Gravatar-0.4.2-py2.py3-none-any.whl
Collecting Flask-Login==0.3.2 (from pgadmin4==1.1)
Collecting beautifulsoup4==4.4.1 (from pgadmin4==1.1)
  Using cached beautifulsoup4-4.4.1-py2-none-any.whl
Collecting django-htmlmin==0.8.0 (from pgadmin4==1.1)
Requirement already satisfied: fixtures==2.0.0 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Requirement already satisfied: itsdangerous==0.24 in ./lib/python2.7/site-packages (from pgadmin4==1.1)
Collecting Flask-Babel==0.11.1 (from pgadmin4==1.1)
Requirement already satisfied: argparse in /usr/lib/python2.7 (from unittest2==1.1.0->pgadmin4==1.1)
Building wheels for collected packages: psycopg2, pycrypto
  Running setup.py bdist_wheel for psycopg2 ... error
  Complete output from command /home/edy/pgadmin4/bin/python2 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-cFch6n/psycopg2/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpvOLZfypip-wheel- --python-tag cp27:
  running bdist_wheel
  running build
  running build_py
  creating build
  creating build/lib.linux-x86_64-2.7
  creating build/lib.linux-x86_64-2.7/psycopg2
  copying lib/errorcodes.py -> build/lib.linux-x86_64-2.7/psycopg2
  copying lib/__init__.py -> build/lib.linux-x86_64-2.7/psycopg2
  copying lib/extras.py -> build/lib.linux-x86_64-2.7/psycopg2
  copying lib/extensions.py -> build/lib.linux-x86_64-2.7/psycopg2
  copying lib/_json.py -> build/lib.linux-x86_64-2.7/psycopg2
  copying lib/psycopg1.py -> build/lib.linux-x86_64-2.7/psycopg2
  copying lib/_range.py -> build/lib.linux-x86_64-2.7/psycopg2
  copying lib/tz.py -> build/lib.linux-x86_64-2.7/psycopg2
  copying lib/pool.py -> build/lib.linux-x86_64-2.7/psycopg2
  creating build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_bugX000.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/dbapi20_tpc.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/testutils.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_quote.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/__init__.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_lobject.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_errcodes.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_extras_dictcursor.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_copy.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_connection.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_module.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_types_extras.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_psycopg2_dbapi20.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/testconfig.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_cursor.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_transaction.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_async.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_types_basic.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_dates.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_notify.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_bug_gc.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_with.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_cancel.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/test_green.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  copying tests/dbapi20.py -> build/lib.linux-x86_64-2.7/psycopg2/tests
  running build_ext
  building 'psycopg2._psycopg' extension
  creating build/temp.linux-x86_64-2.7
  creating build/temp.linux-x86_64-2.7/psycopg
  x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSYCOPG_DEFAULT_PYDATETIME=1 -DPSYCOPG_VERSION="2.6.2 (dt dec pq3 ext lo64)" -DPG_VERSION_HEX=0x090601 -DHAVE_LO64=1 -I/usr/include/python2.7 -I. -I/usr/include/postgresql -I/usr/include/postgresql/9.6/server -c psycopg/psycopgmodule.c -o build/temp.linux-x86_64-2.7/psycopg/psycopgmodule.o -Wdeclaration-after-statement
  In file included from psycopg/psycopgmodule.c:27:0:
  ./psycopg/psycopg.h:30:20: fatal error: Python.h: No such file or directory
  compilation terminated.
  error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

  ----------------------------------------
  Failed building wheel for psycopg2
1

python.h should be included in python-dev-Package. You can install this package with these commands:

sudo apt install python-dev
  • Thanks Phillip! Works like a charm. Oh, also thanks for formatting my post! – Ed Yu Nov 11 '16 at 20:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.