So, I installed Ubuntu alongside Windows 7 just now, on my girlfriend's laptop. I used a USB stick and followed all the default options, choosing a partition size of 32GB for Ubuntu 11.10.

After installation completed, the machine rebooted and now all I'm left with is a command prompt like this:


I was expecting a boot menu rather than this, and I've idea how to proceed. Hoping someone can help.



This means that grub, as an application, has managed to load successfully, but something has stopped it from moving on to ubuntu. chances are this is a problem with the configuration file; although i'm surprised this happened on a fresh install.

The grub> prompt should allow you to restore your system.

As it's difficult to diagnose exactly what is wrong from just knowing you're dropped into the prompt, I recommend you read-up on this:


Simply however, I suspect you'll need to do the following:

  • Seek the linux partition: ls
  • Pick the parition you think you installed Ubuntu on
  • Check that the linux parition has all the files: ls (hdX,Y)/, ls (hdX,Y)/boot and ls (hdX,Y)/boot/grub should all return the names of some files
  • If not, change to another parition or come back here with the output
  • Start the loaded menu: configfile (hdX,Y)/boot/grub/grub.cfg
  • If this doesn't work, come back to askubuntu, or, if you're up to it, you can read how to write a rudimentary configuration in the link I included.
  • Once you've got to Ubuntu in the terminal you must sudo update-grub to save changes.

Personally, if this is a fresh install, I might take a pop at just reinstalling Ubuntu and taking note of the more advance options, specifically where to install grub to.

  • Thanks Thomas. I reinstalled, and now get a grub rescue prompt. With ls, only ls (hd0,5)/ returns anything, including boot/. If I try ls (hd0,5)/boot/ (or any other dir) I get an error: out of disk message. – Winston Smith Dec 3 '11 at 14:23
  • FWIW I was able to boot into Ubuntu using the Live CD, then run the grub-install and update-grub2 commands. They reported installing a config. When I rebooted, I was back to the grub rescue prompt, with the out of disk error. – Winston Smith Dec 3 '11 at 14:39
  • ok- just out of interest do you have more than one hard-disk? if you do then you might need to point your bios to boot from the right one (a quick way of doing this would be to use your bios boot menu...) – thomasmichaelwallace Dec 3 '11 at 15:21
  • No, just one disk. – Winston Smith Dec 4 '11 at 11:25
  • Tried the graphical Boot Repair program, and still no luck. – Winston Smith Dec 4 '11 at 16:49

I was experiencing the same exact issue until I changed the SATA controller mode in the BIOS setup from AHCI to Native IDE.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.