4

For example, in Firefox when I press ctrl + l the url is highlighted. When I change to Hebrew and press ctrl + l (actually ctrl + ך) nothing happens. How can I make all of my keyboard shortcuts work while in a different language?

Most of the similar questions I saw posted here said that it is a bug that will be fixed in the next version. Those posts are all from over a year ago, has the bug been fixed?

2
1

Shortcuts including a character seems to be bound to that character, not to a particular key. For instance, Ctrl+A selects all text when you are typing. If I switch to a French keyboard layout that's still true, even if A is now accessed through another key (i.e. the key which you use to type Q with an English (US) layout.

However, it does not work with non-latin layouts which lack the corresponding English characters. There is a bug report about the problem.

4
  • Do you know if there is a setting or a program that I can use to change the behavior so that it will treat ctrl + ך as ctrl + l?
    – HanMah
    Nov 11 '16 at 7:11
  • @HanMah: No I don't, especially not on Kubuntu. I'd have to google around, but you can do so too. ;) Maybe somebody else has a hint. Nov 11 '16 at 8:01
  • I don't mind attempting to make a program to fix the issue. However, I have no idea where to start. Can you give me some pointers on how to start?
    – HanMah
    Nov 12 '16 at 19:00
  • @HanMah: No, it's over my head. Sorry. Nov 12 '16 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.