1

I have made a fresh Ubuntu GNOME 16.04.1 install through USB and there were no problems during the first boot. Booting my OS a second time throws me immediately to tty1. Here is what I have tried:

  • Booting from my USB again then trying to boot from Hard drive initializes the display successfully. However, as with the original symptom, once I shutdown my computer and re-start it again throws me to tty1
  • in tty1, I have tried issuing service gdm stop & service gdm start with sudo privileges. Nothing worked.
  • in tty1, issuing sudo startx starts my display manager with root as the current user. Using a terminal window, restarting the gdm service as above successfully initiate the GDM with me as the current user.
  • in tty1, typing startx without root privileges fails

Are there any défaux with init scripts ? I have updated my packages.

EDIT 1: Issuing sudo service gdm restart reactivates the graphical tty7 and solves the problem. However, I have to enter it every time at boot. My guess is that there are some components related to GDM initialization that load after GDM or something similar.

EDIT 2: After being dropped to tty1, my "num-lock" flickers very rapidly for about 20 seconds. If I typed my user name and password during this period, I am logged in into the Graphical interface as normal. If not, then I have to manually restart GDM. What is worth noting though, is that every time I change "Automatic Login" to ON, I find it OFF after the next boot.

Note: I have my / encrypted. My "/boot" resides on a separate partition

0

My most accurate guess is that this happens because I have encrypted my home directory (in addition to the disk encryption) during installation:

Entering your credentials

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.