11

I have been using Super+M to access the notifications area then Tab followed by Space to cancel/dismiss notifications.

Is there a "quicker" shortcut (i.e. more direct/immediate action)?

  • I don't have access to a GNOME environment but does pressing escape do anything? – TheOdd Nov 10 '16 at 17:56
  • Did you check dconf ? – M. Becerra Nov 10 '16 at 18:01
  • 1
    I haven't found a real solution yet, but worth noting that you can tab all the way through to "clear all" and enter or space to clear them all at once. Beats clearing them one at a time, at least. – eggsyntax Sep 28 '17 at 17:17
8

Super+N to focus the currently displayed notification followed by Esc works for me.

|improve this answer|||||
0

If you want to disable notifications:

  1. Open the Activities overview and start typing Notifications and click on Notifications to open the panel.
  2. Switch the toggle to OFF.

You can press Super+V to open the notifications tray/calendar.

Notifications will still be available in the message tray when you display it, by clicking on the clock, or by pressing Super + M, and they will start popping up again when you switch the toggle to ON again.

|improve this answer|||||
0

A small hack..
Run the below command in terminal or create a shortcut with the below command.

gdbus call --session --dest org.gnome.Shell --object-path /org/gnome/Shell --method org.gnome.Shell.Eval 'Main.panel.statusArea.dateMenu._messageList._notificationSection._list.remove_all_children()'

enter image description here

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.