I'm trying to setup Ubuntu so that my touchpad on MacBook Air works.

I've successfully installed and am using mtrack, but it still doesn't work. Acceleration is horrible, and the cursor jumps around apparently randomly.

I've edited my xorg.conf file according to tutorials I could find.

I'd like to fix acceleration, and possibly right-clicking by clicking on the bottom-right corner.

Any help appreciated, here's my xorg.conf:

Section "InputClass"
MatchIsTouchpad "on"
Identifier      "Touchpads"
Driver          "mtrack"
Option          "Sensitivity" "0.55"
Option      "FingerHigh" "12"
Option      "FingerLow" "1"
Option          "IgnoreThumb" "true"
Option          "IgnorePalm" "true"
Option          "TapButton1" "0"
Option          "TapButton2" "0"
Option          "TapButton3" "0"
Option          "TapButton4" "0"
Option          "ClickFinger1" "1"
Option          "ClickFinger2" "3"
Option          "ClickFinger3" "3"
Option          "ButtonMoveEmulate" "false"
Option      "ButtonIntegrated" "true"
Option          "ClickTime" "25"
Option          "BottomEdge" "25"
Option      "SwipeLeftButton" "8"
Option      "SwipeRightButton" "9"
Option      "SwipeUpButton" "0"
Option      "SwipeDownButton" "0"
Option      "ScrollDistance" "75"
EndSection

I'd suggest maybe looking at mtrack

I notice you have it configured, but a good idea to check :)

You can get it installed and configured like this:

  • sudo apt-get install xserver-xorg-input-mtrack
  • sudo nano /usr/share/X11/xorg.conf.d/50-synaptics.conf

Change the input section to be something similar to this:

Section "InputClass"
        MatchIsTouchpad "on"
        Identifier      "Touchpads"
        Driver          "mtrack"
        Option          "Sensitivity" "0.95"
        Option          "FingerHigh" "12"
        Option          "FingerLow" "1"
        Option          "IgnoreThumb" "true"
        Option          "IgnorePalm" "true"
        Option          "TapButton1" "0"
        Option          "TapButton2" "0"
        Option          "TapButton3" "0"
        Option          "TapButton4" "0"
        Option          "ClickFinger1" "1"
        Option          "ClickFinger2" "3"
        Option          "ClickFinger3" "3"
        Option          "ButtonMoveEmulate" "false"
        Option          "ButtonIntegrated" "true"
        Option          "ClickTime" "25"
        Option          "BottomEdge" "25"
        Option          "SwipeLeftButton" "8"
        Option          "SwipeRightButton" "9"
        Option          "SwipeUpButton" "0"
        Option          "SwipeDownButton" "0"
        Option          "ScrollDistance" "75"
        Option          "ScrollUpButton" "5"
        Option          "ScrollDownButton" "4"
EndSection
  • Save your config with ctrl+x and y to save and quit nano
  • Reboot

I hope that helps!

Good luck :)

  • Yup, I already have it like I was saying, and x.org logs show that it's loading mtrack. – Niccolò Brogi Nov 10 '16 at 13:20
  • Hmmm, I wonder. Have you tried adding SUSPEND_MODULES="bcm5974" to your /usr/lib/pm-utils/defaults? – ThatGuy Nov 10 '16 at 13:24
  • I didn't! What does it do? – Niccolò Brogi Nov 10 '16 at 13:24
  • Hopefully, it should trigger a restart of the bcm module when it realizes it's not in suspend mode. – ThatGuy Nov 10 '16 at 13:26
  • Woops! I just found a bug report. bugs.launchpad.net/ubuntu/+source/linux/+bug/1586552 – ThatGuy Nov 10 '16 at 13:30

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.