0

I have NVIDIA graphic card along with another card from ASPEED. I would like to use NVIDIA card for scientific computing and ASPEED card for displaying. The ASPEED card works OK initially, but after the NVIDIA driver is installed, it stuck in a login loop.

Below are more information.

pixels@pixels-SYS-7048GR:~$ lspci | grep VGA
02:00.0 VGA compatible controller: NVIDIA Corporation GM200 [GeForce GTX TITAN X] (rev a1)
03:00.0 VGA compatible controller: NVIDIA Corporation GM200 [GeForce GTX TITAN X] (rev a1)
06:00.0 VGA compatible controller: ASPEED Technology, Inc. ASPEED Graphics Family (rev 30)
82:00.0 VGA compatible controller: NVIDIA Corporation GM200 [GeForce GTX TITAN X] (rev a1)
83:00.0 VGA compatible controller: NVIDIA Corporation GM200 [GeForce GTX TITAN X] (rev a1)

pixels@pixels-SYS-7048GR:~$ nvidia-smi
Thu Nov 10 10:38:33 2016
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 367.57                 Driver Version: 367.57                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX TIT...  Off  | 0000:02:00.0     Off |                  N/A |
| 22%   42C    P0    68W / 250W |      0MiB / 12206MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
|   1  GeForce GTX TIT...  Off  | 0000:03:00.0     Off |                  N/A |
| 22%   47C    P0    75W / 250W |      0MiB / 12206MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
|   2  GeForce GTX TIT...  Off  | 0000:82:00.0     Off |                  N/A |
| 22%   46C    P0    72W / 250W |      0MiB / 12206MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
|   3  GeForce GTX TIT...  Off  | 0000:83:00.0     Off |                  N/A |
|  0%   43C    P0    55W / 250W |      0MiB / 12206MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID  Type  Process name                               Usage      |
|=============================================================================|
|  No running processes found                                                 |
+-----------------------------------------------------------------------------+

In the /var/log/Xorg.0.log file, it shows error message. I googled the error message, but no efficient solution found.

(EE) ast: The PCI device 0x2000 at 06@00:00:0 has a kernel module claiming it.

(EE) ast: This driver cannot operate until it has been unloaded.

I think the following is the most relevant one: (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found) pixels@pixels-SYS-7048GR:~$ cat /var/log/Xorg.0.log

X.Org X Server 1.18.3
Release Date: 2016-04-04
[    51.002] X Protocol Version 11, Revision 0
[    51.002] Build Operating System: Linux 3.13.0-86-generic x86_64 Ubuntu
[    51.002] Current Operating System: Linux pixels-SYS-7048GR 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64
[    51.002] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-45-generic root=UUID=2fba102f-2fa2-4dfa-bd89-2ff9da50e97a ro quiet splash
[    51.002] Build Date: 18 May 2016  01:07:07AM
[    51.002] xorg-server 2:1.18.3-1ubuntu2.2 (For technical support please see http://www.ubuntu.com/support)
[    51.002] Current version of pixman: 0.33.6
[    51.002]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    51.002] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    51.002] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 10 09:40:16 2016
[    51.002] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    51.003] (==) No Layout section.  Using the first Screen section.
[    51.003] (==) No screen section available. Using defaults.
[    51.003] (**) |-->Screen "Default Screen Section" (0)
[    51.003] (**) |   |-->Monitor "<default monitor>"
[    51.003] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    51.003] (==) Automatically adding devices
[    51.003] (==) Automatically enabling devices
[    51.003] (==) Automatically adding GPU devices
[    51.003] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    51.003] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    51.003]    Entry deleted from font path.
[    51.003] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    51.003]    Entry deleted from font path.
[    51.003] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    51.003]    Entry deleted from font path.
[    51.003] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    51.003]    Entry deleted from font path.
[    51.003] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    51.003]    Entry deleted from font path.
[    51.003] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/Type1,
        built-ins
[    51.003] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    51.003] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    51.003] (II) Loader magic: 0x56045b3d2da0
[    51.003] (II) Module ABI versions:
[    51.003]    X.Org ANSI C Emulation: 0.4
[    51.003]    X.Org Video Driver: 20.0
[    51.003]    X.Org XInput driver : 22.1
[    51.003]    X.Org Server Extension : 9.0
[    51.003] (++) using VT number 7

[    51.003] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    51.004] (II) xfree86: Adding drm device (/dev/dri/card1)
[    51.004] (II) xfree86: Adding drm device (/dev/dri/card2)
[    51.004] (II) xfree86: Adding drm device (/dev/dri/card0)
[    51.004] (II) xfree86: Adding drm device (/dev/dri/card3)
[    51.004] (II) xfree86: Adding drm device (/dev/dri/card4)
[    51.010] (--) PCI: (0:2:0:0) 10de:17c2:10de:1132 rev 161, Mem @ 0xcf000000/16777216, 0x383fe0000000/268435456, 0x383ff0000000/33554432, I/O @ 0x00006000/128, BIOS @ 0x????????/524288
[    51.010] (--) PCI: (0:3:0:0) 10de:17c2:10de:1132 rev 161, Mem @ 0xcd000000/16777216, 0x383fc0000000/268435456, 0x383fd0000000/33554432, I/O @ 0x00005000/128, BIOS @ 0x????????/524288
[    51.010] (--) PCI:*(0:6:0:0) 1a03:2000:15d9:0852 rev 48, Mem @ 0xcb000000/16777216, 0xcc000000/131072, I/O @ 0x00004000/128
[    51.010] (--) PCI: (0:130:0:0) 10de:17c2:10de:1132 rev 161, Mem @ 0xfa000000/16777216, 0x387fe0000000/268435456, 0x387ff0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    51.010] (--) PCI: (0:131:0:0) 10de:17c2:10de:1132 rev 161, Mem @ 0xf8000000/16777216, 0x387fc0000000/268435456, 0x387fd0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
[    51.010] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[    51.010] (II) "glx" will be loaded by default.
[    51.010] (II) LoadModule: "glx"
[    51.010] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[    51.014] (II) Module glx: vendor="NVIDIA Corporation"
[    51.014]    compiled for 4.0.2, module version = 1.0.0
[    51.014]    Module class: X.Org Server Extension
[    51.014] (II) NVIDIA GLX Module  367.57  Mon Oct  3 20:28:17 PDT 2016
[    51.014] (==) Matched ast as autoconfigured driver 0
[    51.014] (==) Matched nvidia as autoconfigured driver 1
[    51.014] (==) Matched nouveau as autoconfigured driver 2
[    51.014] (==) Matched nvidia as autoconfigured driver 3
[    51.014] (==) Matched nouveau as autoconfigured driver 4
[    51.014] (==) Matched nvidia as autoconfigured driver 5
[    51.014] (==) Matched nouveau as autoconfigured driver 6
[    51.014] (==) Matched nvidia as autoconfigured driver 7
[    51.014] (==) Matched nouveau as autoconfigured driver 8
[    51.014] (==) Matched ast as autoconfigured driver 9
[    51.014] (==) Matched modesetting as autoconfigured driver 10
[    51.014] (==) Matched fbdev as autoconfigured driver 11
[    51.014] (==) Matched vesa as autoconfigured driver 12
[    51.014] (==) Assigned the driver to the xf86ConfigLayout
[    51.014] (II) LoadModule: "ast"
[    51.014] (II) Loading /usr/lib/xorg/modules/drivers/ast_drv.so
[    51.014] (II) Module ast: vendor="X.Org Foundation"
[    51.014]    compiled for 1.18.0, module version = 1.2.6
[    51.014]    Module class: X.Org Video Driver
[    51.014]    ABI class: X.Org Video Driver, version 20.0
[    51.014] (II) LoadModule: "nvidia"
[    51.014] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[    51.014] (II) Module nvidia: vendor="NVIDIA Corporation"
[    51.014]    compiled for 4.0.2, module version = 1.0.0
[    51.014]    Module class: X.Org Video Driver
[    51.014] (II) LoadModule: "nouveau"
[    51.014] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    51.015] (II) Module nouveau: vendor="X.Org Foundation"
[    51.015]    compiled for 1.18.1, module version = 1.0.12
[    51.015]    Module class: X.Org Video Driver
[    51.015]    ABI class: X.Org Video Driver, version 20.0
[    51.015] (II) LoadModule: "modesetting"
[    51.015] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    51.015] (II) Module modesetting: vendor="X.Org Foundation"
[    51.015]    compiled for 1.18.3, module version = 1.18.3
[    51.015]    Module class: X.Org Video Driver
[    51.015]    ABI class: X.Org Video Driver, version 20.0
[    51.015] (II) LoadModule: "fbdev"
[    51.015] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    51.015] (II) Module fbdev: vendor="X.Org Foundation"
[    51.015]    compiled for 1.18.1, module version = 0.4.4
[    51.015]    Module class: X.Org Video Driver
[    51.015]    ABI class: X.Org Video Driver, version 20.0
[    51.015] (II) LoadModule: "vesa"
[    51.015] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    51.015] (II) Module vesa: vendor="X.Org Foundation"
[    51.015]    compiled for 1.18.1, module version = 2.3.4
[    51.015]    Module class: X.Org Video Driver
[    51.015]    ABI class: X.Org Video Driver, version 20.0
[    51.015] (II) ASPEED: Driver for ASPEED Graphics Chipsets: ASPEED Graphics Family,
        ASPEED Graphics Family, ASPEED AST1180 Graphics, AIP100, AIP200
[    51.015] (II) NVIDIA dlloader X Driver  367.57  Mon Oct  3 20:03:48 PDT 2016
[    51.015] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    51.015] (II) NOUVEAU driver Date:   Tue Dec 8 15:52:25 2015 +1000
[    51.015] (II) NOUVEAU driver for NVIDIA chipset families :
[    51.015]    RIVA TNT        (NV04)
[    51.015]    RIVA TNT2       (NV05)
[    51.015]    GeForce 256     (NV10)
[    51.015]    GeForce 2       (NV11, NV15)
[    51.015]    GeForce 4MX     (NV17, NV18)
[    51.015]    GeForce 3       (NV20)
[    51.015]    GeForce 4Ti     (NV25, NV28)
[    51.015]    GeForce FX      (NV3x)
[    51.015]    GeForce 6       (NV4x)
[    51.015]    GeForce 7       (G7x)
[    51.015]    GeForce 8       (G8x)
[    51.015]    GeForce GTX 200 (NVA0)
[    51.015]    GeForce GTX 400 (NVC0)
[    51.015] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    51.015] (II) FBDEV: driver for framebuffer: fbdev
[    51.015] (II) VESA: driver for VESA chipsets: vesa
[    51.015] (WW) Falling back to old probe method for ast
[    51.015] (--) Assigning device section with no busID to primary device
[    51.015] (--) Assigning device section with no busID to primary device
[    51.015] (WW) ASPEED: More than one matching Device section found: Autoconfigured Video Device ast
[    51.015] (--) Chipset ASPEED Graphics Family found
**[    51.015] (EE) ast: The PCI device 0x2000 at 06@00:00:0 has a kernel module claiming it.
[    51.015] (EE) ast: This driver cannot operate until it has been unloaded.
[    51.015] (EE) [drm] Failed to open DRM device for (null): -22
[    51.015] (EE) [drm] Failed to open DRM device for (null): -22
[    51.015] (EE) [drm] Failed to open DRM device for (null): -22
[    51.015] (EE) [drm] Failed to open DRM device for (null): -22**
[    51.015] (II) modeset(0): using drv /dev/dri/card0
[    51.015] (WW) Falling back to old probe method for fbdev
[    51.015] (II) Loading sub module "fbdevhw"
[    51.015] (II) LoadModule: "fbdevhw"
[    51.015] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    51.015] (II) Module fbdevhw: vendor="X.Org Foundation"
[    51.015]    compiled for 1.18.3, module version = 0.0.2
[    51.016]    ABI class: X.Org Video Driver, version 20.0
[    51.016] (WW) Falling back to old probe method for vesa
[    51.016] (II) modeset(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[    51.016] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[    51.016] (==) modeset(0): RGB weight 888
[    51.016] (==) modeset(0): Default visual is TrueColor
[    51.016] (II) Loading sub module "glamoregl"
[    51.016] (II) LoadModule: "glamoregl"
[    51.016] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    51.019] (II) Module glamoregl: vendor="X.Org Foundation"
[    51.019]    compiled for 1.18.3, module version = 1.0.0
[    51.019]    ABI class: X.Org ANSI C Emulation, version 0.4
[    51.019] (II) glamor: OpenGL accelerated X.org driver based.
[    51.034] (EE) modeset(0): eglInitialize() failed
[    51.034] (EE) modeset(0): glamor initialization failed
[    51.034] (II) modeset(0): ShadowFB: preferred YES, enabled YES
[    51.113] (II) modeset(0): Output VGA-1 has no monitor section
[    51.192] (II) modeset(0): EDID for output VGA-1
[    51.192] (II) modeset(0): Manufacturer: DEL  Model: 4071  Serial#: 876098114
[    51.192] (II) modeset(0): Year: 2014  Week: 10
[    51.192] (II) modeset(0): EDID Version: 1.3
[    51.192] (II) modeset(0): Analog Display Input,  Input Voltage Level: 0.700/0.300 V
[    51.192] (II) modeset(0): Sync:  Separate  Composite  SyncOnGreen
[    51.192] (II) modeset(0): Max Image Size [cm]: horiz.: 51  vert.: 29
[    51.192] (II) modeset(0): Gamma: 2.20
[    51.192] (II) modeset(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display


...
...
    [    51.768] (**) RAPOO RAPOO 2.4G Wireless Device: always reports core events
    [    51.768] (**) evdev: RAPOO RAPOO 2.4G Wireless Device: Device: "/dev/input/event3"
    [    51.768] (--) evdev: RAPOO RAPOO 2.4G Wireless Device: Vendor 0x24ae Product 0x2000
    [    51.768] (--) evdev: RAPOO RAPOO 2.4G Wireless Device: Found 9 mouse buttons
    [    51.768] (--) evdev: RAPOO RAPOO 2.4G Wireless Device: Found scroll wheel(s)
    [    51.768] (--) evdev: RAPOO RAPOO 2.4G Wireless Device: Found relative axes
    [    51.768] (--) evdev: RAPOO RAPOO 2.4G Wireless Device: Found x and y relative axes
    [    51.768] (--) evdev: RAPOO RAPOO 2.4G Wireless Device: Found absolute axes
    [    51.768] (II) evdev: RAPOO RAPOO 2.4G Wireless Device: Forcing absolute x/y axes to exist.
    [    51.768] (--) evdev: RAPOO RAPOO 2.4G Wireless Device: Found keys
    [    51.768] (II) evdev: RAPOO RAPOO 2.4G Wireless Device: Configuring as mouse
    [    51.768] (II) evdev: RAPOO RAPOO 2.4G Wireless Device: Configuring as keyboard
    [    51.768] (II) evdev: RAPOO RAPOO 2.4G Wireless Device: Adding scrollwheel support
    [    51.768] (**) evdev: RAPOO RAPOO 2.4G Wireless Device: YAxisMapping: buttons 4 and 5
    [    51.768] (**) evdev: RAPOO RAPOO 2.4G Wireless Device: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    [    51.768] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1:1.1/0003:24AE:2000.0002/input/input3/event3"
    [    51.768] (II) XINPUT: Adding extended input device "RAPOO RAPOO 2.4G Wireless Device" (type: KEYBOARD, id 9)
    [    51.768] (**) Option "xkb_rules" "evdev"
    [    51.768] (**) Option "xkb_model" "pc105"
    [    51.768] (**) Option "xkb_layout" "us"
    [    51.768] (II) evdev: RAPOO RAPOO 2.4G Wireless Device: initialized for relative axes.
    [    51.768] (WW) evdev: RAPOO RAPOO 2.4G Wireless Device: ignoring absolute axes.
    [    51.768] (**) RAPOO RAPOO 2.4G Wireless Device: (accel) keeping acceleration scheme 1
    [    51.768] (**) RAPOO RAPOO 2.4G Wireless Device: (accel) acceleration profile 0
    [    51.768] (**) RAPOO RAPOO 2.4G Wireless Device: (accel) acceleration factor: 2.000
    [    51.768] (**) RAPOO RAPOO 2.4G Wireless Device: (accel) acceleration threshold: 4
    [    51.768] (II) config/udev: Adding input device RAPOO RAPOO 2.4G Wireless Device (/dev/input/mouse0)
    [    51.768] (II) No input driver specified, ignoring this device.
    [    51.768] (II) This device may have been added with another device file.
    [    51.769] (II) config/udev: Adding input device HID 0557:2419 (/dev/input/event4)
    [    51.769] (**) HID 0557:2419: Applying InputClass "evdev keyboard catchall"
    [    51.769] (II) Using input driver 'evdev' for 'HID 0557:2419'
    [    51.769] (**) HID 0557:2419: always reports core events
    [    51.769] (**) evdev: HID 0557:2419: Device: "/dev/input/event4"
    [    51.769] (--) evdev: HID 0557:2419: Vendor 0x557 Product 0x2419
    [    51.769] (--) evdev: HID 0557:2419: Found keys
    [    51.769] (II) evdev: HID 0557:2419: Configuring as keyboard
    [    51.769] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-13/3-13.1/3-13.1:1.0/0003:0557:2419.0003/input/input4/event4"
    [    51.769] (II) XINPUT: Adding extended input device "HID 0557:2419" (type: KEYBOARD, id 10)
    [    51.769] (**) Option "xkb_rules" "evdev"
    [    51.769] (**) Option "xkb_model" "pc105"
    [    51.769] (**) Option "xkb_layout" "us"
    [    51.769] (II) config/udev: Adding input device HID 0557:2419 (/dev/input/event5)
    [    51.769] (**) HID 0557:2419: Applying InputClass "evdev pointer catchall"
    [    51.769] (II) Using input driver 'evdev' for 'HID 0557:2419'
    [    51.769] (**) HID 0557:2419: always reports core events
    [    51.769] (**) evdev: HID 0557:2419: Device: "/dev/input/event5"
    [    51.824] (--) evdev: HID 0557:2419: Vendor 0x557 Product 0x2419
    [    51.824] (--) evdev: HID 0557:2419: Found 3 mouse buttons
    [    51.824] (--) evdev: HID 0557:2419: Found scroll wheel(s)
    [    51.824] (--) evdev: HID 0557:2419: Found relative axes
    [    51.824] (--) evdev: HID 0557:2419: Found absolute axes
    [    51.824] (--) evdev: HID 0557:2419: Found x and y absolute axes
    [    51.824] (--) evdev: HID 0557:2419: Found absolute touchscreen
    [    51.824] (II) evdev: HID 0557:2419: Configuring as touchscreen
    [    51.824] (II) evdev: HID 0557:2419: Adding scrollwheel support
    [    51.824] (**) evdev: HID 0557:2419: YAxisMapping: buttons 4 and 5
    [    51.824] (**) evdev: HID 0557:2419: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    [    51.824] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-13/3-13.1/3-13.1:1.1/0003:0557:2419.0004/input/input5/event5"
    [    51.824] (II) XINPUT: Adding extended input device "HID 0557:2419" (type: TOUCHSCREEN, id 11)
    [    51.824] (WW) evdev: HID 0557:2419: touchpads, tablets and touchscreens ignore relative axes.
    [    51.824] (II) evdev: HID 0557:2419: initialized for absolute axes.
    [    51.824] (**) HID 0557:2419: (accel) keeping acceleration scheme 1
    [    51.824] (**) HID 0557:2419: (accel) acceleration profile 0
    [    51.824] (**) HID 0557:2419: (accel) acceleration factor: 2.000
    [    51.824] (**) HID 0557:2419: (accel) acceleration threshold: 4
    [    51.824] (II) config/udev: Adding input device HID 0557:2419 (/dev/input/js0)
    [    51.824] (II) No input driver specified, ignoring this device.
    [    51.824] (II) This device may have been added with another device file.
    [    51.824] (II) config/udev: Adding input device HID 0557:2419 (/dev/input/mouse1)
    [    51.824] (II) No input driver specified, ignoring this device.
    [    51.824] (II) This device may have been added with another device file.
    [    51.825] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event6)
    [    51.825] (II) No input driver specified, ignoring this device.
    [    51.825] (II) This device may have been added with another device file.
    [    51.825] (II) config/udev: Adding input device HDA Intel PCH Front Headphone (/dev/input/event7)
    [    51.825] (II) No input driver specified, ignoring this device.
    [    51.825] (II) This device may have been added with another device file.
    [    51.825] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event8)
    [    51.825] (II) No input driver specified, ignoring this device.
    [    51.825] (II) This device may have been added with another device file.
    [    51.825] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event9)
    [    51.825] (II) No input driver specified, ignoring this device.
    [    51.825] (II) This device may have been added with another device file.
    [    51.825] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event10)
    [    51.825] (II) No input driver specified, ignoring this device.
    [    51.825] (II) This device may have been added with another device file.
    [    51.826] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=9 (/dev/input/event11)
    [    51.826] (II) No input driver specified, ignoring this device.
    [    51.826] (II) This device may have been added with another device file.
    [    51.826] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event14)
    [    51.826] (II) No input driver specified, ignoring this device.
    [    51.826] (II) This device may have been added with another device file.
    [    51.826] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=9 (/dev/input/event15)
    [    51.826] (II) No input driver specified, ignoring this device.
    [    51.826] (II) This device may have been added with another device file.
    [    51.826] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event12)
    [    51.826] (II) No input driver specified, ignoring this device.
    [    51.826] (II) This device may have been added with another device file.
    [    51.826] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event13)
    [    51.826] (II) No input driver specified, ignoring this device.
    [    51.826] (II) This device may have been added with another device file.
    [    52.693] (II) modeset(0): EDID vendor "DEL", prod id 16497
    [    52.693] (II) modeset(0): Using EDID range info for horizontal sync
    [    52.693] (II) modeset(0): Using EDID range info for vertical refresh
    [    52.693] (II) modeset(0): Printing DDC gathered Modelines:
    [    52.693] (II) modeset(0): Modeline "1920x1080"x0.0  148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync (67.5 kHz eP)
    [    52.693] (II) modeset(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
    [    52.693] (II) modeset(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz e)
    [    52.693] (II) modeset(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
    [    52.693] (II) modeset(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz e)
    [    52.693] (II) modeset(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz e)
    [    52.693] (II) modeset(0): Modeline "1024x768"x0.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz e)
    [    52.693] (II) modeset(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
    [    52.693] (II) modeset(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz e)
    [    52.693] (II) modeset(0): Modeline "1152x864"x0.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz e)
    [    52.693] (II) modeset(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
    [    52.693] (II) modeset(0): Modeline "1920x1080"x60.0  172.80  1920 2040 2248 2576  1080 1081 1084 1118 -hsync +vsync (67.1 kHz e)
    [    53.543] (II) modeset(0): EDID vendor "DEL", prod id 16497
    [    53.543] (II) modeset(0): Using hsync ranges from config file
    [    53.543] (II) modeset(0): Using vrefresh ranges from config file
    [    53.543] (II) modeset(0): Printing DDC gathered Modelines:
    [    53.543] (II) modeset(0): Modeline "1920x1080"x0.0  148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync (67.5 kHz eP)
    [    53.543] (II) modeset(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
    [    53.543] (II) modeset(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz e)
    [    53.543] (II) modeset(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
    [    53.543] (II) modeset(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz e)
    [    53.543] (II) modeset(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz e)
    [    53.543] (II) modeset(0): Modeline "1024x768"x0.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz e)
    [    53.543] (II) modeset(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
    [    53.543] (II) modeset(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz e)
    [    53.543] (II) modeset(0): Modeline "1152x864"x0.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz e)
    [    53.543] (II) modeset(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
    [    53.543] (II) modeset(0): Modeline "1920x1080"x60.0  172.80  1920 2040 2248 2576  1080 1081 1084 1118 -hsync +vsync (67.1 kHz e)
    [  2101.494] (II) evdev: HID 0557:2419: Close
    [  2101.495] (II) UnloadModule: "evdev"
    [  2101.495] (II) evdev: HID 0557:2419: Close
    [  2101.495] (II) UnloadModule: "evdev"
    [  2101.495] (II) evdev: RAPOO RAPOO 2.4G Wireless Device: Close
    [  2101.495] (II) UnloadModule: "evdev"
    [  2101.495] (II) evdev: RAPOO RAPOO 2.4G Wireless Device: Close
    [  2101.495] (II) UnloadModule: "evdev"
    [  2101.495] (II) evdev: Power Button: Close
    [  2101.495] (II) UnloadModule: "evdev"
    [  2101.495] (II) evdev: Power Button: Close
    [  2101.495] (II) UnloadModule: "evdev"
    [  2101.497] (II) Server terminated successfully (0). Closing log file.

What should I do to make the xserver work, or anything else I can test to get further information?

Many thanks.

  • I solved this problem by reinstalling the driver with the following configuration: sudo ./NVIDIAxxxxx.run --no-opengl-files – Amigoshan Nov 11 '16 at 5:25
  • Thanks a lot for a wonderful article. It helped me solved my problem too. I am running a deep learning server, which I believe is the same model as you, and then after I installed nvidia driver, ubuntu failed to log in. It took me three days to find your article and now the problem solved. Thank you. But I wonder have you happened to have a problem with your ASPEED video card with X, the message is possible missing firmware? – Ming Xie May 18 '17 at 3:17
0

I solved this problem by reinstalling the driver with the following Command:

sudo ./NVIDIAxxxxx.run --no-opengl-files

Reference: http://kislayabhi.github.io/Installing_CUDA_with_Ubuntu/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.