1

After upgrading from 14.04 to 16.04 running vim produces output:

vim: error while loading shared libraries: libruby-1.9.1.so.1.9: cannot open shared object file: No such file or directory

This happens as root and user. Have tried uninstalling and reinstalling

  1. sudo apt-get remove --purge vim -y; apt-get autoremove --purge -y
  2. sudo apt-get clean
  3. sudo apt-get install vim

Have tried uninstalling-re-installing from PPA

  1. sudo add-apt-repository ppa:jonathonf/vim
  2. sudo apt update
  3. sudo apt install vim
  4. sudo apt install ppa-purge && sudo ppa-purge ppa:jonathonf/vim
  5. repeat 1-3.

Exact same result. Have installed the libruby package libruby_2.3.0+1_all.deb for xenial (16.04LTS) (libs): Libraries necessary to run Ruby [universe]

I have two Ruby versions installed -

ruby-1.9.1-p431 [ x86_64 ]  
ruby-2.0.0-p643 [ x86_64 ]

as well as system ruby

ruby 2.3.1p112 (2016-04-26) [x86_64-linux-gnu]

Doesn't matter which ruby is default. Still same result. Obviously vim cannot be uninstalled either. Would appreciate any ideas. Thank you.

  • have you tried temporarily uninstalling or reinstalling ruby? – Zanna Nov 10 '16 at 6:23
0

It could be that the long and complicated update process is to blame. See this sticky Ubuntu Forums post. If that were the case, then the fix would be to back up your $HOME folder, wipe the hard drive clean, install a fresh copy of Ubuntu, restore your $HOME folder, and install missing packages. Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.