1

lab:

nr. 1 Host with Ubuntu 16.04LTS - LXD & ZFS

nr. 2 - LXC Container (MAAS & JUJU)

I've already create a container for MAAS, and it's in running state

$: lxc list

+-------------+---------+--------------------+------+------------+-----------+

| NAME | STATE | IPV4 | IPV6 | TYPE | SNAPSHOTS |

+-------------+---------+--------------------+------+------------+-----------+

| xenial-maas | RUNNING | 10.20.40.29 (eth0) | | PERSISTENT | 0

I'd like also create an LXD Xenial controller for JUJU using the following command

$: juju bootstrap lxd xenial-juju --debug

after having started the container

$: lxc list

+---------------+---------+--------------------+------+------------+-----------+

| NAME | STATE | IPV4 | IPV6 | TYPE | SNAPSHOTS |

+---------------+---------+--------------------+------+------------+-----------+

| juju-6f0b4e-0 | RUNNING | 10.20.40.57 (eth0) | | PERSISTENT | 0 |

+---------------+---------+--------------------+------+------------+-----------+

| xenial-maas | RUNNING | 10.20.40.29 (eth0) | | PERSISTENT | 0 |

+---------------+---------+--------------------+------+------------+------- ----+

it gives me the following error:

12:37:11 ERROR cmd supercommand.go:458 failed to bootstrap model: subprocess encountered error code 1

here the debug file https://paste.ubuntu.com/23450682/

while without --debug the error on the screen is the following

2016-11-09 10:16:12 ERROR cmd supercommand.go:458 new environ: creating LXD client: Get https://10.20.40.254:8443/1.0: Unable to connect to: 10.20.40.254:8443 ERROR failed to bootstrap model: subprocess encountered error code 1

after that the container is removed

$: lxc list

+-------------+---------+--------------------+------+------------+-----------+

| NAME | STATE | IPV4 | IPV6 | TYPE | SNAPSHOTS |

+-------------+---------+--------------------+------+------------+-----------+

| xenial-maas | RUNNING | 10.20.40.29 (eth0) | | PERSISTENT | 0

2

It's a bug :

https://bugs.launchpad.net/juju/+bug/1633788

Same problem for me . JUJU take the wrong IP address for LXD node

Where is what I did to be able to juju bootloade.

When the container is RUNNING you can go inside the container and then do this :

iptables -t nat -A OUTPUT -d ${WRONG_IP} -p tcp --dport 8443 -j DNAT --to-destination ${GOOD_IP}:8443

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.