0

I succeed in updating grub menu to shows windows 10 boot loader. However, if I select windows to boot, the screen turn black and then turn into grub background color but frozen, so I'm unable to start windows.

I did encountered this before in my friend's machine, I fix it simply by disabling UEFI, then grub can boot windows normally but mine is different, I see no such options related to UEFI in BIOS settings.

I know how to restore/edit windows BCD, but since I use Ubuntu as my default OS, I don't want to press enter twice (windows boot menu --> grub --> ubuntu) every time I want to boot Ubuntu.

This is my RESULTS.txt after executing Boot Info Script:

  • 1
    Are both Windows & Ubuntu installed in same boot mode either both UEFI or both BIOS? And in Windows 10 have you turned off fast start up or the always on hibernation. Grub only boots working, not hibernated Windows. And can only boot systems installed in same boot mode. May be best to see details: Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info – oldfred Nov 9 '16 at 19:42
  • @oldfred I already disable windows hibernation, windows boot mode is BIOS, and I think grub is using UEFI. The problem is when I enter BIOS setup, I see no such option relates to UEFI/BIOS (unlike in my friend machine). – DMaster Nov 10 '16 at 3:24
  • Please run the Boot Info Script. This will generate a file called RESULTS.txt. Post that file to a pastebin site and post the URL to your document here. This will give us more details about your configuration, which is required to base an answer on more than guesswork. – Rod Smith Nov 10 '16 at 13:46
  • @RodSmith I did, check it out – DMaster Nov 10 '16 at 15:03
  • Looks like a standard setup for a Win 7 upgrade to Win 10 -- like I'm running. Nothing seems obviously wrong. – ubfan1 Nov 10 '16 at 16:23
1

I just find a solution today, it isn't related to BIOS/UEFI but rather graphical/non-graphical user interface: Just disable GRUB2 graphical interface and it works.

Step 1: Edit file /etc/default/grub (as super-user), add (or uncomment) the following line

# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=console

Step 2: Update grub

sudo update-grub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.