4

I just replaced the hard drive on my desktop with an SSD HD. Ubuntu installer doesn't find it, although when I run Ubuntu from the live CD:

  • the HD is detected in GParted, where I was able to create and format partitions.
  • It's detected by the Ubuntu disks utility as well, and the partitions can be mounted, but when I tried to write a file to it it didn't work
  • fdisk /dev/sda gives this:

    Disk /dev/sda: 139.8 GiB, 150039945216 bytes, 293046768 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x7da8b393
    
    Device     Boot     Start       End   Sectors   Size Id Type
    /dev/sda1            2048 293046271 293044224 139.8G  5 Extended
    /dev/sda5            4096  71684095  71680000  34.2G 83 Linux
    /dev/sda6        71686144 102406143  30720000  14.7G 83 Linux
    /dev/sda7       102408192 270344191 167936000  80.1G 83 Linux
    /dev/sda8       270346240 293046271  22700032  10.8G 82 Linux swap / Solaris
    

I tried to change the BIOS SATA parameters to ACHI and tried a few other settings (not sure what that means but saw it might be related), it didn't help.

The HD is not new, it was previously used as RAID in another computer. I don't know how this works so I have no idea if that matters?

Thanks for your help!

  • do you have anything on this disk that you want? – user595510 Nov 9 '16 at 15:37
  • @MarkYisri no it's empty, i just formatted it – Erwan Nov 9 '16 at 15:38
12

If drive was previously part of a RAID set it may have RAID meta-data on it. Change example from sdx to whatever drive is sda, sdb etc.

sudo dmraid -E -r /dev/sdx
| improve this answer | |
4

Just do dd if=/dev/zero of=YOUR_SSD_DRIVE bs=1024k count=10 then try again. This will erase all metadata that may have been on the drive.

| improve this answer | |
  • Thank you, I used the answer above but yours would certainly have done it as well – Erwan Nov 9 '16 at 16:55
  • @Erwan no problem. – user595510 Nov 9 '16 at 22:54
  • 2
    I'd suggest bs=1024k count=10 to only wipe the first 10MB, blowing away the metadata. No need to sit there for a long time and putting more wear on your SSD. – Peter Cordes Nov 9 '16 at 23:30
  • @PeterCordes fair enough. edited. – user595510 Nov 10 '16 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.