1

I love my brand new laptop. Fast processor, m.2 ssd, memory to spare, xUbuntu runs great.

However, the tocuhpad is driving me nuts! As I'm typing the the mouse clicks on whatever window it's over. The worst part is that the feature "Disable Touchpad while typing" that should take care of this does not work.

Lets start with some specs:

#uname -a
Linux PickledPeanuts 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
#cat /etc/issue
Ubuntu 16.04.1 LTS \n \l

#ps ax|grep syndaemo
13764 pts/6    S+     0:00 syndaemon -i 3 -KR
13793 pts/2    S+     0:00 grep --color=auto syndaemo
#xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ELAN1010:00 04F3:3012 Touchpad            id=12   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=15   [slave  keyboard (3)]
    ↳ DELL Wireless hotkeys                     id=16   [slave  keyboard (3)]
#ps ax|grep wm
 2062 ?        S      0:15 xfwm4 --replace
13860 pts/2    S+     0:00 grep --color=auto wm
#dmesg|grep -i elan
[    1.604814] psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x4d5f02)
[    1.617181] psmouse serio1: elantech: Synaptics capabilities query result 0x00, 0x15, 0x10.
[    1.629063] psmouse serio1: elantech: Elan sample query result 0c, 02, 75
[    1.692084] input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input6
[    2.194620] input: ELAN1010:00 04F3:3012 Touchpad as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-4/i2c-ELAN1010:00/0018:04F3:3012.0001/input/input12
[    2.194862] hid-multitouch 0018:04F3:3012.0001: input,hidraw0: I2C HID v1.00 Mouse [ELAN1010:00 04F3:3012] on i2c-ELAN1010:00
#
#synclient 
Parameter settings:
    LeftEdge                = 128
    RightEdge               = 3092
    TopEdge                 = 130
    BottomEdge              = 2292
    FingerLow               = 1
    FingerHigh              = 1
    MaxTapTime              = 180
    MaxTapMove              = 177
    MaxDoubleTapTime        = 100
    SingleTapTimeout        = 180
    ClickTime               = 100
    EmulateMidButtonTime    = 0
    EmulateTwoFingerMinZ    = 282
    EmulateTwoFingerMinW    = 7
    VertScrollDelta         = 80
    HorizScrollDelta        = 80
    VertEdgeScroll          = 1
    HorizEdgeScroll         = 0
    CornerCoasting          = 0
    VertTwoFingerScroll     = 1
    HorizTwoFingerScroll    = 0
    MinSpeed                = 1
    MaxSpeed                = 1.75
    AccelFactor             = 0.0496401
    TouchpadOff             = 1
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 2
    RBCornerButton          = 3
    LTCornerButton          = 0
    LBCornerButton          = 0
    TapButton1              = 1
    TapButton2              = 3
    TapButton3              = 0
    ClickFinger1            = 1
    ClickFinger2            = 3
    ClickFinger3            = 0
    CircularScrolling       = 0
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 0
    CircularPad             = 0
    PalmDetect              = 0
    PalmMinWidth            = 10
    PalmMinZ                = 200
    CoastingSpeed           = 20
    CoastingFriction        = 50
    PressureMotionMinZ      = 30
    PressureMotionMaxZ      = 160
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    ResolutionDetect        = 1
    GrabEventDevice         = 0
    TapAndDragGesture       = 1
    AreaLeftEdge            = 0
    AreaRightEdge           = 0
    AreaTopEdge             = 0
    AreaBottomEdge          = 0
    HorizHysteresis         = 20
    VertHysteresis          = 20
    ClickPad                = 1
    RightButtonAreaLeft     = 1610
    RightButtonAreaRight    = 0
    RightButtonAreaTop      = 1986
    RightButtonAreaBottom   = 0
    MiddleButtonAreaLeft    = 0
    MiddleButtonAreaRight   = 0
    MiddleButtonAreaTop     = 0
    MiddleButtonAreaBottom  = 0
#

Please note the the ETPS/2 Elantech Touchpad is disabled in the mouse and touchpad settings window. When ELAN1010:00 04F3:3012 Touchpad is disabled, the touchpad no longer works (so that is the one that is used.)

What I've tried (with it not making a difference):

  • Standard "Disable Touchpad while typing" option in interface
  • disabling above and running syndaemon -i 3 -DK
  • disabling above and running syndaemon -i 3
  • running syndaemon as root (just in case)

How I know if it works/doesn't work:

  • Continuously tap one key in a window
  • while doing the above tap on the touchpad in another window
  • if focus changes to the other window, the touchpad is not disabling while typing

A couple theory's as to what may be happening:

  • Touchpad driver is just plain not working right
  • syndaemon disabling wrong touchpad entry (how to test/fix?)
  • syndaemon not detecting keyboard activity (how to test/fix?)

I don't want to be a jerk when asking for help, but before someone suggests the "create a batch file to disable the touchpad and map it to a key" workaround. I already know about that, but it's just not a viable solution for me. Most of my time is spent clicking, typing a few lines, clicking again. etc. I am specifically looking to get disable touchpad while typing working. I am quite technical, have been using different flavors of linux for about 18 years, and have been programming for 20 years. However, I do not know the codebases involved and would love some help getting this tracked down.

0

Hi I had the same problem and i figured out a solution. I read somewhere that the drivers for the mouse become confused when there is more than one mouse hardware listed under xinput.

So i have tested it just now and did the following to stop the cursor focus moving elsewhere while typing:

From your xinput list command i see your touchpad that needs to be disabled is ID 14. So just run in the terminal:

xinput set-prop 14 "Device Enabled" 0

Your mouse should still work with both tap and physical click. Now if you type while trying to tap else where it should not lose focus (physical click will still make it lose focus but I havent figured out why that is yet. However its not a big issue for me as I never lean on the pad hard enough while typing to make it click in that way). Now you just need to run this on startup so there arent two different mice detected at once.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.