0

I installed MAAS on my system which consists of a master cluster and four nodes.
For installing I used the autopilot
I use Ubuntu 14.04 LTS Trusty and MAAS Version 1.9.4+bzr4592-0ubuntu1 (trusty1)

I commissioned all nodes successfully but some nodes refuse to deploy (for testing I just tried to deploy via MAAS API)

two nodes have following problem. It seems Ubuntu gets installed successfully but after the reboot the system fails to boot form local disc with following error.

On the screen of the deploying node:
TFTP prefix:
Trying to load;
pxelinux.cfg/01-48-0f-cf-44-75-8e
Booting local disk ...
Cannot read Master Boot Record or sector 0
boot:

and here it gets stuck until a timeout.

From machine events of the deploying node from MAAS API:
Node changed status - From 'Deploying' to 'Failed deployment'
TFTP Request - chain.c32
TFTP Request - pxelinux.cfg/01-48-0f-cf-44-75-8e
PXE Request - local boot

I hope sb can help me, Thanks Thomas

  • Are the nodes dell servers and potentially have 'virtual drives'? – user508889 Nov 9 '16 at 12:30
  • Indeed, these nodes are Dell servers (workstation z840) but each has two physical hard drives and one of them is used for deployment. Moreover I could install openstack landscape on a third Dell node. – Thomas Nov 9 '16 at 15:54
  • I had some dell servers have something labeled as virtual media in the bios. It showed up as a hard drive to maas, once I disabled it in the bios the deployment succeeded. Maybe that applies to you. – user508889 Nov 9 '16 at 18:34
  • I just realized that these are HP servers not Dell, but anyways, there is nothing labeled as virtual media. – Thomas Nov 10 '16 at 7:31
0

The error was in the BIOS configuration, i disabled hard drive booting. solution: Activate hard drive booting in BIOS options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.