1

I have a MAAS 2.1 setup on Ubuntu 16.10 linked with a local KVM. I need to deploy a 14.04 trusty machine but that never succeeds. I can successfuly deploy 16.04 xenial machines but as soon as I try to deploy 14.04 it always goes to failed deployment state.

It seems that curtin does not detect the vda disks. Have tried many things like using sda disks in the vm but no success. Log in MAAS just says that kernel install was not successful or similar.

Commissioning works fine as it uses 16.04 image, as soon as 14.04 install starts it cannot succeed. Any hints? Thanks.

MAAS logs:

Node changed status - From 'Deploying' to 'Failed deployment'   Tue, 08 Nov. 2016 22:43:38
Marking node failed - Installation failed (refer to the installation log for more information). Tue, 08 Nov. 2016 22:43:38
Node installation failure - 'curtin' failed: curtin command install Tue, 08 Nov. 2016 22:43:38
Node installation failure - 'curtin' failed: configuring installed system   Tue, 08 Nov. 2016 22:43:35
Node installation failure - 'curtin' failed: running 'curtin curthooks' Tue, 08 Nov. 2016 22:43:35
Node installation failure - 'curtin' failed: curtin command curthooks   Tue, 08 Nov. 2016 22:43:31
Node installation failure - 'curtin' failed: installing kernel
  • here some logs from MAAS: – MarcoK Nov 8 '16 at 11:47
1

Are you deploying to physical hardware? If so it seems like the Trusty kernel does not have the drivers to access your disks. Try deploying Trusty with hwe-x to get the Xenial kernel. That should allow Trusty to access the disks on your machine.

The best way to do this since this hardware needs at least hwe-x no matter what you deploy. I would set your minimum hardware kernel to "ga-16.04".

| improve this answer | |
  • Thanks Blake for your tip. Will try that. Have tried something similar before and didn't work as juju insisted on 14.04 images. I deploy against KVM with Libvirt. Not physical HW. The vm's are created with virt-install with command: virt-install --cpu host --name vm1 --network default --memory 4096 --disk size=5 --pxe --graphics vnc,password=vnc,listen=0.0.0.0,port=5901 --autostart --boot network,hd – MarcoK Nov 9 '16 at 8:41
  • Thanks @BlakeRouse for your tip. Ok, have tried it and it stays stuck at the allocated stage in MAAS. Juju requests 14.04 image and the minimum kernel is set to 16.04, so the deployment doesn't start. – MarcoK Nov 9 '16 at 9:03
0

ok, got it working. Had to try lots of different settings in MAAS and now it works. If I set minimum kernel in settings it won't work. If I override on the node itself with a hwe-x minimum kernel it does work. Seems there is some incompatibility issue because the new hwe naming format is hwe-16.04.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.