4

My PC was working yesterday without any problem. I shut it down and tried to open this morning. It prints out these messages on the black screen:

systemd-udevd[713]: failed to execute '/bin/systemctl' '/bin/systemctl start --no-block nvidia-persistenced.service': No such file or directory

systemd-udevd[852]: failed to execute '/bin/systemctl' '/bin/systemctl stop--no-block nvidia-persistenced': No such file or directory

It then continued with the login screen. I entered my password and pressed enter. It waited for a while and the login screen reappeared again.

How can I fix the problem?

3

In case someone else has this problem, this is what worked for me:
Press Ctrl+Alt+F1 to open a terminal and login.
Run sudo apt-get install nvidia-current, then sudo reboot
It downgraded to nvidia-304 and everything was fine after reboot

| improve this answer | |
  • I had this message since I upgraded to nvidia-384, but also random freezes after wake-up, which I never had before; hope this will solve this problem too. Thanks! – Edouard Thiel Jul 24 '18 at 5:57
1

It sounds like you've got two problems, the systemd-udevd looks like it is a problem with the Nvidia driver, I managed to cure mine by reinstalling an earlier version from 367.57 back to 340.98, it's all in the Software & Updates screen.

That of course is no good at all if you are in a login loop. I've also had that problem in the past a few times and had to got to the terminal (Ctrl-Alt-F1) and put this code in:

sudo mv ~/.Xauthority ~/.Xauthority.backup

Then

sudo service lightdm restart

That should at least get you past the login loop and change the driver.

| improve this answer | |
  • I tried what you suggest but it didn't help. I also went through other suggested solutions and checks. None of them solved my problem. Since I was in hurry, I had to format my PC. – aburak Nov 9 '16 at 7:38
1

This message appears to be fairly innocuous, not affecting the driver function. You can confirm the driver function by running inxi -Fxz : you should see something like:

Graphics: Card: NVIDIA Device 1b81 bus-ID: 01:00.0 Display Server: X.Org 1.15.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1920x1080@60.0hz GLX Renderer: GeForce GTX 1070/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 375.82 Direct Rendering: Yes

I get the OP's error message running Linux Mint Rosa 17.3, which does not use systemd (it uses upstart init). Thus, no surprise that /bin/systemctl does not exist. Nvidia should not be trying to call it.

More info in this thread.

If you're unable to log in, there's likely something else wrong.

| improve this answer | |
  • 1
    FYI for those reading: inxi is very useful, but it doesn't come standard on Ubuntu 16.04 and must be installed with sudo apt-get install inxi – cygnus_x1 Sep 26 '17 at 23:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.