I recently upgraded to Maverick and X stopped working. I used to run NVIDIA-96, but now when I modprobe nvidia I'm getting the following error:

FATAL: Error inserting nvidia (/lib/modules/2.6.35-22-generic/kernel/drivers/video/nvidia.ko): No such device

Installing 96-series driver from nvidia.com yields the same result. I also tried to run on nouveau drivers, but it can only give me 640x480 resolution, which is not acceptable.

Graphics card details are:

# lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] [10de:0181] (rev a2)

Is there any PPA with updated driver?

  • Even if its talking about Karmic, this bug report might be usefull, especially from the point of view of purging the Nvidia driver to make NV driver work. Your cards are the same. – marenostrum Oct 20 '10 at 13:43
  • Which way you've used while upgrading to Maverick? If it was a Web upgrade, try a fresh install. If it was a fresh install, install back Lucid, make it properly work with the driver of your choice and perform a Web upgrade. I'm gambling but it may work. – marenostrum Oct 20 '10 at 14:00

Nvidia 96 drivers are not released for maverick (xorg 1.9) yet. But work is in progress. It will be available soon. http://www.nvnews.net/vbulletin/showpost.php?p=2326233&postcount=5

For now, you can downgrade xorg to 1.7 or even downgrade to Lucid.

EDIT: Now you can use 96 drivers!!! http://www.nvnews.net/vbulletin/showthread.php?p=2341157

sudo add-apt-repository ppa:dajhorn/nvidia-96
sudo apt-get update
sudo apt-get install nvidia-96
sudo nvidia-xconfig
sudo nano /etc/X11/xorg.conf

Add to Section "Device"

Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"

reboot and profit!

| improve this answer | |

Seen this?

I gave up some time ago on these old cards, replacing them with newer technology thanks to eBay.

| improve this answer | |

There's a fixed version of nvidia-96 (96.43.19) in the maverick-proposed repository. I was able to fix my system (GeForce 4MX) by enabling the proposed repository (including setting up "selective upgrading") and then running the command:

sudo aptitude -t maverick-proposed install nvidia-96 nvidia-96-modaliases

and then rebooting my machine.

| improve this answer | |

this is because you don't have this routine compiled for this kernel.

nvidia-glx-96 nvidia-96




.. Check this to completely uninstall.

sudo aptitude purge nvidia-glx-96 nvidia-96 nvidia-96-modaliases nvidia-common nvidia-96-kernel-source

then the follow :

sudo apt-get install nvidia-glx-96 nvidia-96 nvidia-96-modaliases nvidia-common nvidia-96-kernel-source

and in the final of this process, you can see this :

First Installation: checking all kernels...

Building only for 2.6.35-22-generic

Building initial module for 2.6.35-22-generic


nvidia-96.ko: at this point you now have the nvidia driver compiler for this kernel

Running module version sanity check.

  • Original module

    • No original module exists within this kernel
  • Installation

    • Installing to /lib/modules/2.6.35-22-generic/updates/dkms/


DKMS: install Completed.

now you can go to System - Administration - Hardware Controler and you can see the new controler there and you can enable it...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.