0
DP-1 connected primary 1440x900+1920+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1440x900      59.89*+
   1920x1080     60.05    60.00    50.04  
   1280x720      60.00    59.94    50.00  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94 

This is the output I get from xrandr -q

$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1c82 (rev a1)

All of the resolutions work (are bad looking though), but the only one that doesn't work (the one I want) does not. All I get is No signal from my monitor when I do this:

xrandr --output DP-1 --mode 1440x900

Additional info:

$ dpkg -l | grep nvidia
ii  nvidia-370                                 370.28-0ubuntu0~gpu16.04.2                    amd64        NVIDIA binary driver - version 370.28
ii  nvidia-opencl-icd-370                      370.28-0ubuntu0~gpu16.04.2                    amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                               0.8.2                                         amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                            370.28-0ubuntu0~gpu16.04.1                    amd64        Tool for configuring the NVIDIA graphics driver

Model: Samsung LE19R86BD

$ cvt 1440 900
# 1440x900 59.89 Hz (CVT 1.30MA) hsync: 55.93 kHz; pclk: 106.50 MHz
Modeline "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync
$ xrandr --newmode "1440x900_59.89"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync
$ xrandr --addmode DP-1 "1440x900_59.89"  
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  37
  Current serial number in output stream:  38

marked as duplicate by Elder Geek, Eric Carvalho, Kevin Bowen, Zanna, TheWanderer Nov 9 '16 at 0:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @ElderGeek not sure what you mean. That is the output it gives me. My monitor doesn't have the option to change it to 59.89. – icancto Nov 7 '16 at 19:12
  • I see that. The question is whether it's accurate for your monitor. Make and model might be useful. – Elder Geek Nov 7 '16 at 19:20
  • @ElderGeek not really. My resolution IS listed. Besides, I get BadMatch error everytime I try to add a mode. – icancto Nov 7 '16 at 19:23
  • What's the actual FULL output for xrandr -q ? You cut off the outputs – Elder Geek Nov 7 '16 at 20:16
0

Try xrandr --newmode 900p 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync

or

xrandr --addmode 900p 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync

Also related: Can I force VGA signal output even when xrandr shows 'disconnected'?

According to the Specifications for your screen.

Supported Computer Resolutions 1024 x 768 (XGA), 1152 x 864, 1360 x 768, 640 x 350, 640 x 480 (VGA), 720 x 400, 800 x 600 (SVGA)

You might find 1360x768 gives better results. (that's the resolution I use when using my TV as a monitor)

Source:

https://stackoverflow.com/questions/851704/xrandr-errors-badname-named-color-or-font-does-not-exist

  • Doesn't let me switch to it. – icancto Nov 7 '16 at 19:51
  • Updated answer. – Elder Geek Nov 7 '16 at 19:56
  • But why does it still give me BadMatch? I can't add a new mode. – icancto Nov 7 '16 at 20:01
  • It appears that there is an incompatibility between xrandr and the Nvidia driver – Elder Geek Nov 7 '16 at 20:07
  • I managed to add it through the NVIDIA X Server and still no signal :-( – icancto Nov 7 '16 at 20:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.