2

I run an Ubuntu/Gnome 16.04 on an XMG A516 with an Nvidia GeForce GTX 965M. Right now I only use the Nouveau Driver, as you can see in the picture. The problem is I think the fan for the GPU is not working because the right side of my laptop gets pretty hot after some time and I do not hear any sound from this fan. In contrast the fan for the CPU works perfect (left side). Also lm-sensors is not detecting any fans or GPU temperature.

I read that I need to install the nvidia driver for it to work, but if I do this after reboot I boot to a black screen (tried with apt-get install nvidia-367 and the .deb from Nvidia homepage). So I purge/remove the nvidia driver and here we go Ubuntu gives me a GUI again. For me it is okay if I do not use my Nvidia card, but I am not okay with my notebook overheating. I appreciate any hints you can give me!

Software Center Picture

sudo sensors-detect sudo sensors

acpitz-virtual-0
Adapter: Virtual device
temp1:        +45.0°C  (crit = +120.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +45.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:         +43.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:         +43.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:         +42.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:         +42.0°C  (high = +100.0°C, crit = +100.0°C)

Some System information

uname -a

Linux dddd 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

sudo lshw -C display,cpu

  *-cpu                   
       description: CPU
       product: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
       vendor: Intel Corp.
       physical id: 17
       bus info: cpu@0
       version: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
       serial: To Be Filled By O.E.M.
       slot: U3E1
       size: 1578MHz
       capacity: 3500MHz
       width: 64 bits
       clock: 100MHz
       capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch epb intel_pt tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm mpx rdseed adx smap clflushopt xsaveopt xsavec xgetbv1 dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp cpufreq
       configuration: cores=4 enabledcores=4 threads=8
  *-display UNCLAIMED
       description: VGA compatible controller
       product: GM206M [GeForce GTX 965M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:df000000-df07ffff
  *-display
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915_bpo latency=0
       resources: irq:127 memory:dd000000-ddffffff memory:a0000000-bfffffff ioport:f000(size=64)
0

I had better luck with the Proprietary GPU drivers team PPA.

You'll have to add their repository to your system and install the latest mainline driver from there:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update && sudo apt-get -y upgrade
sudo apt-get install nvidia-390

A reboot should result in a working system.

Erratum:

One note to mention is that your platform runs NVIDIA's Optimus, and based on the Skylake+ line of systems may require specific workarounds to boot up correctly. I'd recommend applying the workaround below before rebooting.

Please refer to this entry on the Bumblebee project issue tracker on Github.

The arguments I'd recommend adding to /etc/default/grub 's kernel command line based on your specific platform are:

acpi_osi=! "acpi_osi=Windows 2009"

Then regenerate the grub configuration by running:

sudo update-grub

Followed by a reboot.

Test and report back on your findings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.