1

I have windows 7 installed on EFI, I installed Ubuntu on legacy as Windows had secure boot on and I had a message which asked to install Ubumtu on legacy instead of EFI. Now when I boot the laptop, windows starys automatically, if I want to acccess Ubumtu, I have to emter bios and select booting from ubuntu grub(2 are listed for some reason), when the menu appears, an option to boot into either Ubuntu or Win7 is shown.

How do I solve this problem to get the grub showing at boot?

Here is a link to Bootinfo Summary: http://paste2.org/9kwD8mf8

6
  • 1
    Windows 7 does not support UEFI Secure Boot. Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info
    – oldfred
    Nov 7 '16 at 15:42
  • @oldfres done, I editted the original text with a link to pastebin.
    – Amine
    Nov 7 '16 at 15:57
  • Your installs are all UEFI. But you booted Boot-Repair in BIOS/Legacy/CSM boot mode. Best to boot in UEFI mode all the time including all repair flash drives/installers. Report does not show all UEFI boot entries. Do you have ubuntu, Windows and an UEFI hard drive entry? What brand/model system? Some brands need specific work arounds.
    – oldfred
    Nov 7 '16 at 16:54
  • It's an HP, I tried installing Ubuntu on EFI but it said it might cause deletion of my Windows. That's why I used the non EFI installation.
    – Amine
    Nov 7 '16 at 17:27
  • You have Ubuntu installed in UEFI boot mode. But HP are not dual boot friendly. Many work arounds. askubuntu.com/questions/486752/… and: askubuntu.com/questions/597052/… and: ubuntuforums.org/…
    – oldfred
    Nov 7 '16 at 18:11
-1

Disable secureboot from BIOS settings and then clean install Ubuntu on EFI. Don't forget to turn secureboot on back. Worked on my machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.