11

I am using play on linx and I want to to install Starcraft with it but it fails every time I try to. I install it successfully but then when I run battle.net it either doesn't open or crashes instantly.I tried different Wine versions same crash every time.

I am running Ubuntu 16.04 with i7 4790k and a GTX 980

  • 1
    Please run battle.net from terminal via "wine <battlenetwhatever.exe>" and edit your answer with errors. In addition, have you tried increasing Wine's GPU memory (winetricks videomemorysize=<sizegreaterthan512>)? – negusp Nov 7 '16 at 14:09
  • I figured out the problem. I need Visual C 2015 which isnt on playonlinux yet – tomkis Nov 7 '16 at 14:28
  • 1
    I guess, in that case, you could follow this page: appdb.winehq.org/objectManager.php?sClass=version&iId=33156 until you get your support, or test it yourself. – negusp Nov 7 '16 at 14:30
  • Well considering this doesnt run, I can't fix the issue – tomkis Nov 7 '16 at 14:34
23

PlayOnLinux does a terrible job with Starcraft II at the time of this writing. If your end goal is playing Starcraft II on Linux, here's what worked for me, on Ubuntu 17.04

  1. Remove PlayOnLinux entirely.

    sudo apt-get remove playonlinux
    
  2. Tear out the wine that ships with the OS.

    sudo apt-get remove wine
    sudo apt autoremove
    
  3. Enable 32 bit architecture

    sudo dpkg --add-architecture i386
    
  4. Add the repo for wine staging.

    sudo add-apt-repository ppa:wine/wine-builds
    
  5. Update and install

    sudo apt-get update
    sudo apt-get install winehq-staging
    
  6. Grab battle.net installer

    wget https://www.battle.net/download/getInstallerForGame?os=win&locale=enUS&version=LIVE&gameProgram=BATTLENET_APP && mv getInstallerForGame\?os\=win Battle.net-Setup.exe
    
  7. Configure wine by running winecfg and then adjust settings according to the screenshot below. Change out the resolution with your native resolution.

    winecfg
    

    Wine Configuration Screenshot

  8. Run it with wine

    wine Battle.net-Setup.exe
    
  9. From there you can pretty much kick off any Blizzard game such as Starcraft II, Diablo 3, or Heros of the Storm on Ubuntu but I've only tested this with Starcraft II.

Furthermore, I had to jump through some extra hoops to get my gaming laptop here to actually use the better of the two graphics card it has inside it. If you're in this boat too, you'll need to keep reading to get Starcraft II just right.

  • Launch "System Settings"
  • Open "Software and Drivers"
  • Access the tab, "Additional Drivers"
  • Switch to the latest binary drivers from the vendor. (Sorry Open Source community - I like Starcraft)

    Binary Drivers selected

  • Then tell Linux to always use your beefy card

    nvidia-settings
    
  • And set the Prime Profile to NVIDIA

--- This gets you running, but not stable. If I was playing in game more than a couple minutes I got an unhelpful blizzard error. So did some additional changes that have stabilized me.

    sudo apt-get install winetricks winbind

    winetricks corefonts vcrun2005 vcrun2008 vcrun2015

    cd "/home/rakaim/.wine/drive_c/Program Files (x86)/Blizzard App/Battle.net.8394"

    mv "Battle.net Helper.exe" "Battle.net Helper.exe.old"

Installed winetricks and some supporting software. Then I had to rename the Battle.net Helper.exe to old.

Edit: I noticed that this directory "Battle.net.8394" changes it's numbers on each Battle.net update. Take care to make the changes you need in the latest installed version.

Edit: New errors suggested that I needed to install winbind. It appears to have helped.

Edit: Upgraded to Ubuntu 17.04

gl hf

  • I had to use the instructions on the wine-staging website to get winehq-staging installed: wine-staging.com/installation.html – dolphone bubleine Aug 12 '17 at 1:41
  • on step 8 I get: $ wine Battle.net-Setup.exe fixme:winediag:start_process Wine Staging 2.20 is a testing version containing experimental patches. fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org. wine: cannot find L"C:\\windows\\system32\\Battle.net-Setup.exe" – ubuntubu Nov 12 '17 at 2:43
  • It's important to remove the wine directory beforehand for this answer to work. rm -rf ~/.wine . Be careful not to mess up that remove command. – 6ft Dan Nov 15 '17 at 13:14
  • FYI you can just do: wget -O Battle.net-Setup.exe https://www.battle.net/download/getInstallerForGame?os=win&locale=enUS&version=LIVE&gameProgram=BATTLENET_APP – The Mighty Chris Dec 28 '17 at 20:50
  • 1
    Do you have a working update for Ubuntu 18.04? Just did a fresh install of linux and wine and can't install starcraft...I got to remove wine and got the error "virtual packages like 'wine' can't be removed" – Assimilater May 25 '18 at 3:23
2

You need to do advance set up (custom) and install some libs separately, when installing with POL. I am playing SC2 on Ubuntu 16.04. It is still crashing sometimes unfortunately. AFAIR, I more or less followed this https://www.youtube.com/watch?v=jv8s0_5YvLg

These are the native libs I have configured for SC2 (Configure -> Wine -> Configure Wine):

Wine native overrides

  • Could you include a bit more information in your post? Link-only answers are requests for deletion here. – anonymous2 Nov 7 '16 at 18:26
  • This reference is truly important even though its not a good answer as per stack overflow I find it very useful for anyone interested in the question – zardilior Jul 12 '17 at 17:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.