2

I am new to Ubuntu.

My problem is the strange appearance of Nautilus (or Unity?)

enter image description here

Maybe I have messed up with the tweak tool, so I have deleted the tweak tool and its preferences.

Also tried to reset nautilus and unity to default settings. Didn't help.

How can I repair?

  • 1
    You are right: that isn't the default look of Nautilus – user595510 Nov 7 '16 at 11:41
  • what tweak tool did you use? – user595510 Nov 7 '16 at 11:42
  • unity tweak tool, - launchpad.net/unity-tweak-tool – yonder Nov 7 '16 at 11:48
  • To me there is nothing awfully wrong... what exactly is it you feel is not right? – Takkat Nov 7 '16 at 12:32
  • Which Ubuntu version are you using? – Anwar Nov 7 '16 at 12:36
3

This is an issue caused by incompatibility of the default Ambiance theme with the Nautilus version.

GNOME developers love to break this and that between GTK releases. Since Ubuntu 16.04 is shipped with mostly GTK 3.18 components including nautilus, updating the nautilus and GTK with break the compatibility of those applications with default Ambiance theme.

You need to downgrade to default nautilus and GTK. I think you've added gnome3-staging PPA.

So, remove it with this command

sudo ppa-purge ppa:gnome3-team/gnome3-staging

If you prefer to stay with GTK 3.20 in 16.04, You have to find themes that work well with GTK-3.20.

The list of themes that supports GNOME 3.20 is few. Here is a list

If you want to use default Ambiance theme:

If you really want to use the Ambiance and Radiance theme, you can download the light-themes package from Yakkety release and install it in 16.04. It works fine in my test.

  • This helped, thank you very much! What can i do for you?) – yonder Nov 8 '16 at 17:14
  • @rainbow Glad that this helped. You've accepted the answer. That worked as thanks :) – Anwar Nov 8 '16 at 17:16
  • @rainbow May I ask what exactly helped? Did you purge the repository? or installed the theme from Yakkety? – Anwar Nov 8 '16 at 17:20
  • When i tried to purge the repository in terminal, it didn't work, there was some kind of a mistake. But i removed it in the software center. It didn't change the situation, so i installed the Ambiance theme and everything was fixed. – yonder Nov 8 '16 at 20:00
0

To get started, press Ctrl+Alt+T to open a terminal window. When it opens, run the below command to reset Unity and Compiz settings:

dconf reset -f /org/compiz/

After that, run the below command to restart Unity:

setsid unity
  • Ok, nothing changed. – yonder Nov 7 '16 at 11:52
  • reboot the computer – user595510 Nov 7 '16 at 11:55
  • Nothing changed. – yonder Nov 7 '16 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.