I have 3rd gen Intel mobile CPU i5-3210M, with integrated HD4000 graphics.How can I tell what driver version (i915) I have and does it support Vulkan? What Mesa version I have in Kubuntu 16.10?

What happens if I run a game made with Vulkan API without Vulkan support in driver?

  • 2
    glxinfo | grep version to see which mesa version you have. In my case on KDE 16.10 this is 12.0.3.
    – Bruni
    Nov 7, 2016 at 10:05
  • Thanks @Bruni. I can see now that I have Mesa 12.0.3 too. And in Mesa wiki website I read that version 12.0 supports Vulkan 1.0 postimg.org/image/rm37shrtl
    – Hrvoje T
    Nov 7, 2016 at 11:06

4 Answers 4


a Simple way is to look the unofficial vulkan gpu database https://vulkan.gpuinfo.org

The best way is to install vulkaninfo utility from your repository manager, like apt-get install vulkaninfo, emerge or pacman

It does depend upon hardware, though, most of the late decade gpu are compatible. Then, it needs support from drivers, o.s. and game.

I'm afraid in your case, i915, does not support Vulkan at all (see https://wiki.gentoo.org/wiki/Vulkan for more about i915 not being able to run Vulkan software)

  • 4
    On Ubuntu 20.04, it's apt-get install vulkan-tools, then run vulkaninfo.
    – talljosh
    Sep 23, 2020 at 0:33
  • What does vulkaninfo show if I do not have vulkan support? It prints pages and pages of info when I run it.... which I assume means it's working?
    – AnnanFay
    May 7 at 15:25
  • ERROR: [Loader Message] Code 0 : vkCreateInstance: Found no drivers! Cannot create Vulkan instance. This problem is often caused by a faulty installation of the Vulkan driver or attempting to use a GPU that does not support Vulkan.
    – Marcelo
    May 8 at 21:33

According to Intel: (Intel open source graphics drivers and vulkan graphics api) support for Vulkan is seamlessly built into Linux PC distributions.

Whether or not Vulkan or OpenGL support is built into a given game is up to that game's developer not to your hardware/firmware or software drivers.

As comment below points out the above "seamless" integration is for 6th generation CPUs. For IvyBridge (HD4000) and newer Vulkan support it is built into Mesa 13 Intel-Vulkan driver that can be downloaded here: (archlinux.org vulkan-intel) and is discussed in detail here: (Mesa 13). Note Mesa driver 13 was released November 1, 2016 and is a great improvement over version 12.

  • 'The Intel’s Open Source Vulkan driver for 5th generation Intel® Core™ processors and 6th generation Intel® Core™ processors (code-named Broadwell and Skylake) passes the Vulkan 1.0 Conformance Test Suite on these platforms and has experimental support for older platforms.'
    – Hrvoje T
    Nov 7, 2016 at 10:21
  • @HrvojeT So right you are. I've updated the answer for HD4000 models. Nov 7, 2016 at 10:38
  • 1
    and also Mesa 12.0 according to Mesa wiki postimg.org/image/rm37shrtl
    – Hrvoje T
    Nov 7, 2016 at 11:09
  • 1
    Yes Mesa 12.0 first introduced Vulkan support I believe. But the last link says how it was much improved under Mesa 13.0 which was released 6 days ago. Nov 7, 2016 at 11:15

Installing and using vulkaninfo

Vulkan has a standard set of tools available for all platforms. On Ubuntu this is available by installing the vulkan-tools package.

You can then use vulkaninfo to see detailed information about your Vulkan installation. I'd advise running it with vulkaninfo | less or piping its output to a text file as it can be large.

You can see the available Vulkan-supporting GPUs on your system in a couple of places here. For example the Presentable surfaces section has a subsection for each Vulkan-capable GPU you have.

It's important to know that a GPU called llvmpipe or softpipe is a software-emulated vulkan device. Thanks to the hard work of its developers it is possible to use vulkan without any dedicated hardware by translating it using llvm into native CPU code - but as expected it's much slower. Low-demand 3d software could still use Vulkan, but it's almost certain unsuitable for things like gaming. If that is the only Vulkan device listed, then your dedicated hardware doesn't support Vulkan, or its driver isn't properly installed and working.

If you don't even have llvmpipe, then it's possible Vulkan itself isn't properly installed (libvulkan1 and mesa-vulkan-drivers).

Finally, if you use Vulkan in 32-bit apps it uses a different Vulkan loader and Vulkan drivers, so you should install and check the 32-bit vulkaninfo in such a case.


It appears that if the GPU isn't running an ancient driver, it mostly definitely supports Vulkan.

So you can check if the old "radeon" driver is in use with:

lspci -v | grep --after-context=12 VGA | grep "Kernel driver in use:" | cut --delimiter=":" --fields=2 | xargs | grep --quiet --invert-match "radeon"; echo $?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .