I have installed ubuntu server 11.10 on my pc. But I decided to install an ubuntu-desktop package as I would like to have a possibility to start GUI when I would need it. So I ran command: sudo apt-get install ubuntu-desktop

Now when I want to change to GUI mode I run command: startx

and there is a problem becouse I get GUI which is not coplete. There is a upper control panel, but there is a white wallpaper and windows dont's show up. I would attach a picture but I can't becouse I'm new user.

Could anybody help me ?

  • I would like to mention that when I boot from usb Ubuntu 11.10 desktop there is the same issue as I wrote. But when I boot Ubuntu 10.04.3 desktop there is everything ok. – user36372 Dec 2 '11 at 21:14
  • I looked at lightdm.log file and there is a fail: Failed to load session file /usr/share/xgreeters/.desktop: No such file or directory and it results in Failed to start greeter and next logs apply to stopping X server, Display server, Display Manager and so on.. – user36372 Dec 2 '11 at 23:02


sudo start lightdm

to start the graphical login screen an then do a normal login. Use

sudo stop lightdm

if you want to disable the GUI again.

  • when I use this command there is some messages printed on my screen like: starting openSSH server , web server apache2 and the last message is Checking battery state.. and nothing more happens..screen is locked.. but I can change to tty1-6 by typing Alt+1..6 – user36372 Dec 2 '11 at 20:19

It sounds like nautilus is not starting up properly. When you start up the GUI, you may be able to use one or more of the following ways to open a terminal to investigate.

Does the unity dock open (the sidebar)? If so, the topmost entry should have the Ubuntu logo and say "Dash home" when you hover over it. Click on it and type in "Terminal" at the search prompt.

If the dock isn't loading properly, try pressing Alt+F2. This should bring up a prompt that says "Run a command". Type gnome-terminal and press Enter.

Check if nautilus is running.

$ pidof nautilus

should print out the PID of the nautilus process If not, your problem might go away by typing

$ nautilus& disown

How to fix it permanently is another issue...

  • I did what you said but when I ran terminal there smth like arrows on the left side bar indicating that terminal is opened but there is no icon. When I move the mouse over the place where should be an icon of terminal label "terminal" shows up. I went to text mode by typing Ctrl+Alt+F2 and ran those commands. It printed out the PID of the nautilus.. – user36372 Dec 2 '11 at 19:48
  • Oh, okay. Well, the missing (transparent) icon probably means that the icon for the terminal can't be found. As for the commands, there is some program missing (or it seems), but nautilus is my usual culprit. Can't think of others. – jpaugh Dec 3 '11 at 22:04

It sounds like some packages may have been missed. You need to make sure you have enabled Universe and multiverse repositories in your /etc/apt/sources.list file.

Once you have enabled them you need to run sudo apt-get update

Then you should try sudo apt-get install ubuntu-desktop again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.