0

Please excuse me if this has been asked many times before. I couldn't find the answer here or anywhere else Google lead me. I like Rich Text Format files. I don't wish to discuss or debate my preferences, okay?

What I would like to learn is how to make all .rtf files on my Ubuntu 16.04 installation cease being executable now and forever until the end of time!

I cannot remove the check from the 'run as executable' box under Properties of each individual file. It just magically resets itself. I have moved all of the .rtf files into a single directory, opened the directory in Terminal and tried using the chmod command half a dozen different ways to remove the files executable capabilities, but the files executable capabilities remain intact.

If the executable function of rich text format files absolutely and unequivocally cannot be remove, then please tell me. Otherwise there must be a Ubuntu zen master (or mistress) who can show me the way.

closed as unclear what you're asking by muru, Zanna, amc, waltinator, Pilot6 Nov 10 '16 at 15:31

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Are the files on a FAT or NTFS filesystem? – Olathe Nov 7 '16 at 0:23
  • Out of curiosity, what is the issue with being marked as executable? Is it a security concern or something I'm unaware of? Also, you could try a sticky bit like chmod * 1666. – ThatGuy Nov 7 '16 at 0:44
  • rtf files are not executable anyway. They are data files that can be opened with some applications like LO. You can remove association with LO. – Pilot6 Nov 7 '16 at 1:18
  • The chmod command that you'll probably need to use is... open terminal, cd to the directory where you've put the .rtf files, then type sudo chmod -x *.rtf. – heynnema Nov 7 '16 at 16:08
2

Open Nautilus.

Navigate to one of the RTF files in question and left single click on it. Not a double click, a single left click to give it focus.

Hover your mouse over the top menu bar to make the "File, Edit..." menu appear then use:

  1. Click Edit drop-down menu
  2. Click Preferences option
  3. Click Behavior tab
  4. Observe the radio option buttons under Executable Text Files
  5. Check radio button View executable text files when they are opened

Note though when you do this and double click on a Bash Script file it will be opened with the default text editor selected instead of being executed.

  • Thank you! Your tutorial solved my issue. I did edit the tutorial you wrote as there were some mis-spellings and one error in the directions provided. – user609012 Dec 4 '16 at 16:03
  • @DarkStar Thank you for your edits. Often our own eyes can't correct everything as we research and answer questions . Community efforts to improve Q&A spelling, grammar and typos makes AskUbuntu a better resource for all of us. – WinEunuuchs2Unix Dec 4 '16 at 19:10