8

Icons won't show up on the GNOME 3 desktop. Terminal commands or Tweak Tool won't work.And i do have some stuff, the desktop folder isn't empty.

  • Which version of Ubuntu GNOME and GNOME are you running? – user364819 Nov 6 '16 at 18:25
3

The GNOME 3 DE is designed to be used without having icons on the desktop, so desktop icons are not supported on the standard GNOME 3 desktop environment. But for users who want to work with icons on the desktop, an alternative is offered. You'll have to log out and switch the user session to GNOME Classic mode. Log back in and now you are able to use desktop icons in GNOME DE.

  • I'm using "GNOME on Wayland". – Arynn Nov 6 '16 at 18:35
  • @Arynn : Then you have to stick with the default standard GNOME 3 desktop environment as it is intended to be used ... or ... switch the session to GNOME Classic mode from the login screen. :) – cl-netbox Nov 6 '16 at 18:37
  • I never tried GNOME 3 Classic, i only tried normal GNOME 3 and GNOME on Wayland. Regular GNOME 3 had a really buggy Shell Menu (If i click on "show apps" and then search something, the search results will overlap the apps). Does the same happen in Classic? – Arynn Nov 6 '16 at 18:42
  • 1
    @Arynn : You will just have to try it out - if you are satisfied, go with GNOME Classic (including desktop icons), if you don't like it, stick with GNOME 3 standard ... but your main question is answered, right ? :) – cl-netbox Nov 6 '16 at 18:46
  • Sure, i'll try. – Arynn Nov 6 '16 at 18:59
1

This seems to be solved in Ubuntu 17.10 (currently in development).

  • It doesn't work on my freshly upgraded 17.10 – z33k Jan 18 '18 at 18:34
0

Gnome on Wayland doesn't support icons.

0

You can enable Gnome desktop icons, whether you're on Wayland or Xorg. Open a terminal and enter the following command (for a more detailed answer, see my answer here):

sudo setcap -r /usr/bin/gnome-shell

Hope it helps. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.