2

I recently changed the grub parameters to this (via grub manager):

GRUB_HIDDEN_TIMEOUT=0.0
GRUB_TIMEOUT=0.0

because I wanted GRUB to shows only if I pressed shift and I wanted my pc to automatically boot to windows if I didn't press anything.

Unfortunately I can't display GRUB by pressing Shift on start, my pc automatically boot to windows and I can't go back to Ubuntu to change the setting.

(It's normal that it boot to windows automatically because I specified it in the GRUB settings)

Do you know a way to either access grub or access Ubuntu ?

I tried to boot override from UEFI to Ubuntu but I still go to windows...

Thank you.

  • 1
    UEFI uses escape key not shift that BIOS uses. So if UEFI boot try Escape key. – oldfred Nov 6 '16 at 18:09
  • Actually, the key used to access EFI/UEFI boot options is NOT standardized. Common options include Esc, Enter, and various function keys (especially F2, F10, and F11, but sometimes something else). – Rod Smith Nov 7 '16 at 14:54
0

The first step is to install a Windows program to access Linux partitions from within Windows as described here: (Best way to access ext partion in windows)

The next step is to edit /boot/grub/grub.cfg and search for timeout changing the value from 0 to 5.

Save the file and reboot.

Note that after rebooting Ubuntu you still need to change /etc/default/grub otherwise the next time you run sudo update-grub the timeout will go back to zero.

  • @Tom23 Glad to hear it. Don't forget to check the answer as the solution so others know it will work for them too. – WinEunuuchs2Unix Nov 6 '16 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.