4

I'm having various issues with rendering text in Matlab 2016b after doing the upgrade to 16.04. Here are some example screenshots:

Glitching in menu

Invisible text in profiler

I have already checked the classic Ubuntu issue with sub-pixel anti-aliasing causing text to disappear, but this does not seem to be the issue.

lshw gives the following output:

  *-display               
       description: VGA compatible controller
       product: Broadwell-U Integrated Graphics
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:50 memory:f5000000-f5ffffff memory:d0000000-dfffffff ioport:f000(size=64)
  *-display UNCLAIMED
       description: 3D controller
       product: GM108M [GeForce 845M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:d000(size=128) memory:f7000000-f707ffff

Anyone have any idea what could be causing this?

  • I wouldn't: I would add the graphics tag so the next user looking for the same problem will find it easier... Also: delete all of your comments to keep things tidy here as it's starting to look like a chat room here! :D – Fabby Nov 6 '16 at 21:37
3

From the output of the lshw command, I can safely conclude you forgot to install the nVidia drivers...

So have a look here on how to install them and then the problem will go away!

:-)

| improve this answer | |
2

For those of us who don't happen to have a spare NVIDIA card lying around: I think the problem is related to the Intel driver and can be fixed by enabling antialiasing.

Enabling font antialiasing in MATLAB:

Select Preferences -> Fonts -> [x] Use antialiasing to smooth desktop fonts (requires MATLAB restart)

| improve this answer | |
  • I had no idea that Matlab had it's own setting for this. This is actually a system wide issue with Ubuntu on some laptops, so I might add that the steps from the following answer (on another question) should be followed if this is the source of the issue: askubuntu.com/a/68029/616016 This is just based on my experience however, I have not done any targeted testing. – Emil Andre Løvbak Dec 18 '16 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.