3

I just started using my new Dell XPS 13 Developers Eddition with Ubuntu 16.04. I am used to triggering the Unity Launcher with the Super / Windows key, and triggering the list of shortcuts by holding that key. However, with the default setup, hitting Super alone does nothing. In addition, when I try assigning Super to trigger the Unity launcher from unity-tweak-tool it will not let me (though I can assign an trigger it with another key).

Notice that in unity-tweak-tool, nothing shows up as the shotcut for "Show the launcher". If I click "Restore defaults" it is the same.

enter image description here

I have also confirmed that the Super works fine when paired with other keys.

Is there any way for me to trigger the Unity launcher with Super as has been the default in t he past? I am also curious why it would not be working out of the box.

4

Maybe Dell changed some things, I'd ask them 1st if the laptop came with Ubuntu.

Otherwise install compizconfig-settings-manager & look in the unity plugin > Launcher, see screen. The x button on far right sets to default which is Super & enabled.

enter image description here

  • 1
    Thanks for this solution! I did this, and removed the dell-super-key package based on this answer. I am not sure if this solution would have worked without that, or if removing that package would have been enough, but either way, it i s fixed now. I did have to restart in order for it to work though. – elethan Nov 7 '16 at 0:35
  • So it looks like Dell did indeed change this. On some slow day I'd probably call support & inquire as to why.. – doug Nov 7 '16 at 1:03
  • I gather from this answer that it is actually for legal reasons - I guess not being able to tie the Windows-branded key to an Ubuntu feature? That seems ridiculous, but is also not at all surprising to unfortunately. As a commenter points out in that thread, it would have been nice if they would have put an Ubuntu logo on the super key like System 76 does, but I guess they couldn't be bothered... – elethan Nov 7 '16 at 2:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.