I'm completely new to Linux and just installed Ubuntu 16.04 LTS with Windows 10. (I've installed Ubuntu on a different partition than Windows, if that would be of any help). So I set up Ubuntu but my Ethernet is not being detected and connected. The same works fine when on Windows. I've searched other questions on this site but none of them solved my problem. I would be glad if someone helped me out here! Thanks!

Okay, so I am the user who put a bounty on the question. I was unable to comment due to lack of reputation. But now I think I should take the reins of this question into my hands. So, I will describe my system's properties.

I had installed Ubuntu 16.04 on a separate partition in parallel to Windows 10. The laptop is Lenovo Z51-70. The problem is that the ethernet is not connecting on Ubuntu.

This is the result of "ipconfig" on Windows.

Windows IP Configuration

Wireless LAN adapter Local Area Connection* 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::d01f:a297:5f9c:80f%4
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :

Ethernet adapter Ethernet 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Wireless LAN adapter Wi-Fi:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Ethernet adapter Bluetooth Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{5F5A44D4-1648-49E4-8C87-54CB2AB99206}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter Local Area Connection* 12:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Also, I would like to add that rebooting didn't help. Restarting network-manager didn't help. Giving up IP on Windows before booting into Ubuntu didn't help.

The output of the script which @DavidFoerster mentioned is at wireless-info.txt.

  • Are you sure it isn't just working? Is it some kind of exotic usb wifi device? In the top-right corner there should be some icon gives a menu for network options (normally an icon of two arrows going back and forward). Might want to check that. Also, what does it say when you run ifconfig in a terminal (start terminal using [CTRL]+[]ALT] + [T]. Also check if you don't have special rules in your router that might block the connection. Maybe you could add some additional info after trying these suggestions. Feb 1, 2017 at 23:34
  • it's very hard to install Linux on the same partition as Windows, due to the lack of POSIX permissions on Windows file systems
    – phuclv
    Feb 3, 2017 at 11:13
  • 1
    how can this question be answered without hardware details?
    – Zanna
    Feb 4, 2017 at 7:30
  • @Zanna problem is there can be too many answers, one for every combination of network card and software setup. OP hasn't signed on since November 6, 2016 when question was posted so further details may not be forthcoming. Usually a question like this gets closed but because of bounty the rules of the game change: Post an answer the bounty bank-roller likes best :p Feb 4, 2017 at 16:14
  • @WinEunuuchs2Unix well yeah exactly. Without hardware details from the bank roller, answerers can only speculate (as they are doing)
    – Zanna
    Feb 4, 2017 at 16:18

7 Answers 7


The bible of network connection problems

The best place to start is with your favorite bible of network connections like this (wiki.archlinux.org - Enable WOL in Windows driver) from ArchLinux.

Although there are dozens of things you can try:

1 Check the connection 2 Set the hostname
2.1 Local network hostname resolution 3 Device driver
3.1 Check the status
3.2 Load the module 4 Network interfaces
4.1 Device names
4.1.1 Get current device names
4.1.2 Change device name
4.1.3 Reverting to traditional device names
4.2 Set device MTU and queue length
4.3 Enabling and disabling network interfaces 5 Configure the IP address
5.1 Dynamic IP address
5.1.1 systemd-networkd
5.1.2 dhcpcd
5.1.3 dhclient
5.1.4 netctl
5.2 Static IP address
5.2.1 netctl
5.2.2 systemd-networkd
5.2.3 dhcpcd
5.2.4 Manual assignment
5.2.5 Calculating addresses 6 Tips and tricks
6.1 ifplugd for laptops
6.2 Bonding or LAG
6.3 IP address aliasing
6.3.1 Example
6.4 Change MAC/hardware address
6.5 Internet sharing
6.6 Router configuration
6.7 Promiscuous mode 7 Troubleshooting
7.1 Swapping computers on the cable modem
7.2 The TCP window scaling problem
7.2.1 How to diagnose the problem
7.2.2 Ways of fixing it Bad Good Best
7.2.3 More about it
7.3 Realtek no link / WOL problem
7.3.1 Enable the NIC directly in Linux
7.3.2 Rollback/change Windows driver
7.3.3 Enable WOL in Windows driver
7.3.4 Newer Realtek Linux driver
7.3.5 Enable LAN Boot ROM in BIOS/CMOS
7.4 No interface with Atheros chipsets
7.5 Broadcom BCM57780
7.6 Realtek RTL8111/8168B
7.7 Gigabyte Motherboard with Realtek 8111/8168/8411 8 See also

We'll start with the most likely based on limited information given that the network card works in Windows but not Ubuntu. This is outlined in the next section.

Windows disables NIC (Network Interface Card) on shutdown

When a BIOS feature known as Wake on LAN (WOL) is disabled your NIC will have no blinking LED's indicating connection and no connection to your router. Windows can disable your NIC on shutdown. To prevent this from happening on Realtek cards under Windows XP (example) use:

Right click my computer and choose "Properties"
--> "Hardware" tab   --> Device Manager
 --> Network Adapters
  --> "double click" Realtek ...
   --> Advanced tab
    --> Wake-On-Lan After Shutdown
     --> Enable

This may not solve the OP problem because exact details are not given. However there is a high degree of confidence that one of the other solutions on this web page will solve the problem.


I found this website helpful running Ubuntu 18.04 on Alienware M15 with the Killer Wireless AX1650, it's a guide for installing the driver. Note that secure boot must be disabled. The guide applies for Ubuntu 16.04 / 18.04 / 19.04. https://support.killernetworking.com/knowledge-base/killer-ax1650-in-debian-ubuntu-16-04/

As of 10/24/19, the website's instructions read:

Enter the following commands into a Terminal one line at a time.

Step 1 – Download the Latest Git and Build-Essential packages

sudo apt update
sudo apt-get install -y git
sudo apt-get install -y build-essential

Step 2 – Download the Iwlwifi-Firmware.git repository

git clone git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
cd linux-firmware
sudo cp iwlwifi-* /lib/firmware/
cd ..

Step 3 – Download the Backport-Iwlwifi.git repository Because ‘Make will be producing an Unsigned Driver, you will probably see SSL errors / warnings. This is fine, but this is the reason Secure Boot must be Disabled. If Secure Boot is Enabled your Computer will not use an Unsigned Driver!

git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
cd backport-iwlwifi
sudo make defconfig-iwlwifi-public
sudo make -j4
sudo make install

The following command might be necessary to force your machine to use the Driver from boot:

update-initramfs -u

Reboot your machine!


I have had this same problem the last few weeks (Dec. 2020). I dual boot Linux Mint 20 and Windows 10 (this one only for gaming). After a certain Windows update, at every reboot from Windows to Linux the NIC wouldn't work at all. Disconnecting the power cord for a while was a workaround. The UEFI is configured with Wake-on-LAN disabled. The solution came from configuring the NIC in Windows this way:

  • Disable Wake-on-LAN
  • Disable PME

After changing this settings, the problem was gone: rebooting from Windows to (or powering-off and restarting in) Linux works normally, as it should.


I am not an expert by any means, but I also encountered this issue when I first started using a dual booted computer. I am using 14.04 which has a similar problem. From what I was able to find online (both here and other tech sites), it appears to be an issue with the Ethernet card configuration. From what others have said, Windows and Ubuntu use different Ethernet card configurations. Because of the way Windows works, it configures the card in a manner such that Ubuntu cannot reconfigure it. The easiest way around this is to have Windows "release" the Ethernet card. However, Windows does this only during a complete shutdown; not during a restart. It is not the same going in the other direction. Windows is able to reconfigure the Ethernet card after Ubuntu has used it.

In summary, rebooting from Ubuntu to Windows is okay. A complete shutdown of Windows and then a boot into Ubuntu is okay. What is not okay is rebooting from windows into Ubuntu. I have tried searching for a way to force Ubuntu to reconfigure the card. I have also searched for a way to force Windows to "release" the card on reboot as if it were a complete shutdown. However, my searches have turned up nothing so far.

  • I can't comment on the original post because of the reputation requirements. However, I would like to re-emphasize that a complete shutdown should work. By this, I do not mean a restart or reboot; there is a difference. I mean the case where you have to physically press the power button on the computer to turn it back on. When doing a full shutdown, the computer should not be turning on by itself. Feb 6, 2017 at 17:46

First check if the Ethernet card driver is working fine in your installation.

lspci | grep -i eth

This will give a output like the following:

Ethernet controller: Intel Corporation Ethernet Connection I217-LM (rev 05)

If the output is blank, edit /etc/NetworkManager/NetworkManager.conf file and set managed=true . restart the network manager sudo service network-manager restart.

You can also try compat-wireless-2.6.tar.bz2 driver.


This appears more like a driver issue, since this is fine with Windows 10. You may have issue with the ethernet card drivers in Ubuntu.

I believe the option mentioned in this link will help. If the input doesn't work, let me know your ethernet card details, and output of ifconfig, and /etc/network/interfaces

  • This appears more like a comment then an answer. :) Feb 7, 2017 at 14:34

I had a similar problem with a Debian 10 and Windows 10 dual boot. The solution was to do a "real" shutdown of Windows 10 by disabling fast boot in Control Panel -> Power Options -> Choose what the power buttons do -> Change settings that are currently unavailable -> Unckeck Turn on fast startup and then Save changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.