0

This question already has an answer here:

How do I tell GRUB to boot Ubuntu in command-line and not to load any AMD graphics drivers?

It seems that my laptop's Graphics card is broken - there are blue stripes. I am able to get to the GRUB menu with these blue stripes. However, once I chose "recovery mode" the screen just freezes and cursor keeps blinking forever. My goal is to somehow boot into system and copy all personal files to a remote host, but I can't do that presumably because Ubuntu tries to load AMD GPU driver and switches graphics mode. The same issue happens also If I try to boot my system with USB flash drive.

marked as duplicate by Byte Commander, Eric Carvalho, WinEunuuchs2Unix, Zanna, waltinator Nov 7 '16 at 14:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Also as the root cause probably is a hardware defect of your graphics card, maybe cooling it down can temporarily improve the display quality to help you getting your data off. Had a similar issue on an old notebook once and there the amount of artefacts was proportional to the device temperature. – Byte Commander Nov 6 '16 at 0:29
  • @ByteCommander I can't get into the original system anymore to type "update-grub" so at least the answer in that question does not fit my needs. – Hans Solo Nov 6 '16 at 0:41
  • You can also edit the boot options from the GRUB menu by pressing the e key while having the entry you want to modify selected. – Byte Commander Nov 6 '16 at 15:52
1

I figured this out myself. I just had to create an Ubuntu Server (and not Desktop) flash drive. Then I was able to successfully boot in rescue command line.

It seems that busybox shell environment on Ubuntu server image does not come with scp tool. So I just had to let the recovery tools to mount the previous partition to be able to copy over my files to a backup server.

Not the answer you're looking for? Browse other questions tagged or ask your own question.