Running Ubuntu 16.04 on a Dell XPS 13

I've just installed the OS and am dual booting with Windows 10. I'm brand new to Linux and wanted to give Ubuntu a try but I can't get any audio to play, however it works fine in Windows. My sound card isn't being recognized, aplay -l returns no soundcards found. I've tried reinstalling alsa and pulseaudio but that's done nothing. lspci -v returns:

00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21) (prog-if 80)

Subsystem: Dell Device 075b
Flags: fast devsel, IRQ 255
Memory at dc428000 (64-bit, non-prefetchable) [disabled] [size=16K]
Memory at dc400000 (64-bit, non-prefetchable) [disabled] [size=64K]
Capabilities: <access denied>
Kernel modules: snd_hda_intel

As I say I'm brand new to linux and wanted to ease myself in gently but this is turning into a headache. Any help would be greatly appreciated.

3 Answers 3


I found a Solution: the installation of dkms audio upgrade did it. Instructions are here : https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

See you

  • I'd been seeing my sound card intermittently disappear. Installing DKMS seemed to fix my problem at first, but later that day the sound card disappeared again.
    – Zaz
    Jun 6, 2017 at 16:58
  • for bionic there are only tar/dsc files, how to run the last command using these files? sudo dpkg -i will not work on the tar file
    – Derek Eden
    May 11, 2020 at 2:50

This bug may be the same problem you are having, https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1551880, What you can try is upgrading the kernel module. you can upgrade to as high as the newest kernel by going to http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8/ put the three files for your architecture in a separate folder and then open that folder in a terminal window and type sudo dpkg -i *.deb, reboot and see if the sound card is recognized. you can also research and find the module for your sound car build and install it into your current kernel. that is a little more complicated as you will have to build the module, insmod and then do a modprobe.

  • 1
    Can you please describe what to do step by step cus I feel lost, and I've the same problrm
    – youta
    Nov 24, 2016 at 6:39
  • Are you running 32bit or 64 bit? click on the kernel link above, download the the kernel modules for the 32 bit or 64 bit. you should download the all file and the two generic kernel module. Create a folder to move them into. the open a terminal in that folder and at the prompt; type "sudo dpkg -i *.deb" without the quotes. then reboot. Nov 27, 2016 at 21:00

I was experiencing a similar issue. It turns out that the drivers were technically classed as 3rd-party drivers, so they were being disabled by UEFI secure boot. When I disabled this in BIOS, everything worked fine :)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.