1

I am a newbie to Ubuntu and installed Ubuntu 16.04 in my Acer ES1-521 laptop. WiFi worked right after the installation, but now i see Wireless adapter is hard blocked.

Machine has a Qualcomm Atheros 9565 card. There is no switch to turn off/on wifi. Only the Fn + F3.

Seems the hard block started after i switched off and on bluetooth. Not sure it caused it or just a coincidence.

I had tried the following to remove hard unblock.

rfkill unblock all modprobe ath9k Bios reset (F9) - Wifi card works just fine in Windows 10 before and after bios reset

None of the above could unblock wifi.

any other suggestions please?

Thanks

0

I had same issue with Acer ES1-521 laptop. Following Link here, I did the following and it worked fine.

blacklist acer-wmi

to my /etc/modprobe.d/blacklist.conf. Then a quick reboot and wireless network detected and working fine from then on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.