1

Since my in-place upgrade from 16.04 to 16.10, the Juniper Network Connect VPN client has been failing silently. I'm running it in 32-bit Firefox using 32-bit Oracle Java, and it worked quite well under 16.04. I did an in-place upgrade to 16.10. I do not believe the Mad-Scientist scripts will help me here, though I'm willing to try to make that work as well.

The applet runs normally, connects, builds the tunnel, and I receive my DHCP assigned address for tun0. All appropriate routes are added for the tun0 interface.

No traffic actually routes to tun0 however, for instance if I ping a host on the other end of the tunnel the traffic counters never increase.

I've installed 16.10 fresh from DVD onto a spare hard drive, went through the song and dance of getting 32-bit Oracle Java and FF installed and working, and have the exact same issue on the new build. Network Connect runs, connects, stays connected, however no traffic ever hits tun0.

There are no errors logged either in the NCSVC/NCUI logs, or in syslog. I feel like I must be missing something immediately obvious, but can't for the life of me see what it might be.

I've seen people in other threads seemingly mention that this works for them under 16.10 (Juniper Network Connect not working on ubuntu 16.04), so I believe it must be possible.

I'm happy to provide logs, but nothing really shows any errors. NCSVC log just shows all the routes being added, and the only thing in the main syslog is the DNS servers changing to those provided by the VPN, which then obviously fail to connect, and trying to fall back to UDP.

2

I had the same problem, and it seems to be a kernel bug (again). Before launching the VPN client, type this command as root:

echo 0 > /proc/sys/net/ipv6/conf/default/router_solicitations

The source for this information is from this bug report.

  • That's nearly got me there. After echoing to router_solicitations, joining the VPN would cause a few KB to cross in each direction, but I still wasn't routing. However you did put me onto the fact it's a kernel regression, and I was able to fall back to an older kernel, fixing my issue. – xrayspx Nov 16 '16 at 22:53
1

After reading https://bugzilla.redhat.com/show_bug.cgi?id=1343091, there is a workaround that finally worked for me:

echo 1 | sudo tee /proc/sys/net/ipv6/conf/all/disable_ipv6

All credits to Jason Elwell

  • Disabling IPv6 altogether doesn't appear very attractive. – guntbert May 16 '17 at 20:21
  • I deeply agree with you, but with kernel 4.8.0-52-generic #55~16.04.1-Ubuntu SMP Fri Apr 28 14:36:29 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux, previous workaround didn't work – Federico Gaule Palombarani May 17 '17 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.