146

In previous versions I could tweak the keyboard repeat delay and speed by going to Settings → KeyboardTyping. Now in Ubuntu GNOME 16.10 (with GNOME 3.20.2) that panel seems to be missing.

How can I configure those settings in this version?

5 Answers 5

210

These settings are under Settings → Universal AccessTypingRepeat Keys. You have to click the Repeat Keys row item, which brings up a pop-up dialog with two settings: Delay and Speed.

enter image description here

This works in Ubuntu 17.04 and above.

In older versions of Ubuntu, the Speed setting worked in reverse: the lower the speed, the faster the repeat rate. This is no longer the case.

12
  • 7
    Have you clicked on Repeat keys? Because a menu appears allowing you to set the speed.
    – Loque
    Commented Feb 28, 2017 at 19:21
  • 6
    OK, so apparently my gsettings command did successfully set Delay to its lowest setting, and Speed to its highest setting. None the less, the repeat rate is significantly slower than it was in past versions of Gnome. Why enforce these arbitrary restrictions? Commented Mar 1, 2017 at 2:46
  • 22
    Bad interface change. "Repeat keys" shows just "On". It is more than natural that the user will think that clicking on it will turn it "Off", when in fact it opens a new window! And who would've thought, the configuration we're looking for is right there. Btw, had the same issue with Ubuntu 18.04. Commented May 1, 2018 at 19:07
  • 21
    Great UI design. Why would you put keyboard settings in Settings->Keyboard? Haha that'd be stupid! We should hide them in accessibility under what looks like a toggle-button but isn't instead... Edit: Speed is backwards? Oh my god someone designed this??
    – Timmmm
    Commented Oct 28, 2018 at 18:56
  • 3
    Please upvote this bug so the GNOME maintainers understand how unfortunate these design decisions were. Commented Dec 31, 2018 at 18:31
57

On ubuntu 14.04 and up this will survive after reboot:

gsettings set org.gnome.desktop.peripherals.keyboard repeat-interval 30
gsettings set org.gnome.desktop.peripherals.keyboard delay 250

delay is given in milliseconds.

repeat-interal is also given in milliseconds which is different to the Xorg xset r rate command which uses Hz.

5
  • 12
    This is much better for portable configurations than settings menu, because you can set the exact values instead of blindly adjusting a slider
    – siikamiika
    Commented Dec 5, 2018 at 8:43
  • Thanks! And FWIW, this should work on any OS using Gnome. Commented Dec 8, 2018 at 7:40
  • What units are those numbers? Seem like delay is milliseconds? But repeat-interval seems to be frequency (hz)? A higher number repeats the keypress faster. E.g. A value of 50 is faster than 30.
    – MiniGod
    Commented Mar 10, 2021 at 12:48
  • This is a much better answer
    – blueether
    Commented Jan 30, 2022 at 18:23
  • It introduced me to gsettings! Indeed for this kind of tuning CLI is more efficient. Commented May 29 at 14:53
33

If nothing else works, and if you are using the Xorg (i.e. not Wayland), try running xset r rate 220 40 from a console.

xset r rate <milliseconds_before_repeating> <repetitions_per_second>

See man xset for more info:

If the server supports the XFree86-Misc extension, or the XKB extension, then a parameter of 'rate' is accepted and should be followed by zero, one or two numeric values. The first specifies the delay before autorepeat starts and the second specifies the repeat rate. In the case that the server supports the XKB extension, the delay is the number of milliseconds before autorepeat starts, and the rate is the number of repeats per second. If the rate or delay is not given, it will be set to the default value.

For me, the HID layer got broken in some way and config GUI didn't work, gsettings didn't work, only xset worked.

This solution however is not persistent - will disappear on restart (unless added to ~/.bashrc).

4
  • +1 Lubuntu 18.04.2 uses this method instead. See file ~/.config/autostart/LXinput-setup.desktop
    – ATorras
    Commented Apr 17, 2019 at 15:48
  • best solution to my problem, as i'm using a window manger without a desktop environment. this line is very handy.
    – Boson Bear
    Commented Jul 7, 2020 at 23:01
  • perfect, it works everywhere ! Commented Sep 12, 2022 at 14:05
  • seems not work in U22 anymore: ``` xset r 10 10 xset: unknown option run ``` Commented Apr 22, 2023 at 18:59
1

I'm a Ubuntu 18.04.3 User.... and not a techie. I tried changing the kdrate in terminal. I was told it had changed, but it didn't change the slow keyboard input.

This low tech method worked for me:

Go to "Show Applications", where there's an "InputMethod" utility, which has a keyboard as the icon. Open this.... ignore the warnings. Select "Yes" then you are presented with a list of options. The one which worked for me is "auto activate IM with @mark for most locales". You need to reboot your PC/laptop.

Then you can go to "Settings", "Typing", and then click on "repeat keys" and "cursor blinking". Both these options have sliders which you can use to speed up and slow the keyboard and key strokes.

I tried looking at the Keyboard Documentation. I didn't understand it, so I hope this answer works for Ubuntu users like me.

1
  • Hi! I followed your steps but still didn't get those sliders you mention.
    – user116813
    Commented Oct 7, 2019 at 9:32
0

You need to set DISPLAY and username. You can look here:

https://www.kodmanyagha.com/blog/cinnamon-keyboard-settings-resetting-after-wake-up/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .