1

I am just setting up a new linux-only system, with supermicro motherboard X10SRL-F, Xeon chip, and GeForce 1070 GPU. Hardrives are set to legacy (not UEFI), secure boot is disabled, though CSM is still enabled.

Ubuntu install works fine, and I switched the processor to the intel proprietary drivers and installed intel gpu tools and rebooted, no problems. Ran sudo apt-get update, reboot, no problems. However, I have tried both switching to Nvidia driver 367 in the system settings and running sudo apt-get install nvidia-current (which should be driver 367), and both lead to a login loop on reboot. I have also tried install driver 361, same issue.

I have already tried everything suggested here: Ubuntu gets stuck in a login loop, the permissions were not the problem, I have also uninstalled and reinstalled lightdm, again no help. I believe I have tried everything I can find at this point, any help would be greatly appreciated.

Edit: have run sudo apt-get purge nvidia* and then reinstalled, as well as a fresh install of ubuntu 16.04, did not help

Edit: have also tried switching to gdm3 (different error), caused a different error, did not resolve the issue. Also, running sudo apt-get install ubuntu-desktop, did install something, but still got the login loop on reboot.

  • If nvidia-367 really does not work, you could try driver nvidia-370 (sudo add-apt-repository ppa:graphics-drivers/ppa sudo apt-get purge nvidia-* sudo apt-get install nvidia-370). This driver version should support GeForce GTX 1070 too. – Axel Richter Nov 6 '16 at 10:29
  • Thanks! I just tried this, gave me error: "E: unable to locate package nvidia-370" – Nicolaus Schmandt Nov 6 '16 at 18:43
  • Never mind, just needed a sudo apt-get update for it to work, but I still have the login loop – Nicolaus Schmandt Nov 6 '16 at 18:50
1

To all who might be having this problem, what ended up fixing it for me was disabling the onboard video in my motherboard. I'm not sure why that did it but according to someone else it was causing the video to keep resetting. Something to try.

0

Nvidia 10-series GPU hangs on 16.04, I had to use Ubuntu 17.04 on my desktop with nvidia 1060. Hope this helps.

protected by Community Sep 8 '17 at 18:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.