0

Edit - Update I have found a file with the original passphrase from the failed to upgrade 14.04, and I have also confirmed on the current 16.04 that that same passphrase exists. By using

:/home$ sudo ecryptfs-unwrap-passphrase /home/lenub/.ecryptfs/wrapped-passphrase
[sudo] password for john2: Passphrase: 
{passphrase displayed}

That seems to indicate I may in fact still have the original files, but can not decrypt and mount them.


This is very similar to “sudo ecryptfs-recover-private” gives “find: ‘/run/user/1000/gvfs’: Permission denied” after botched (?) upgrade although in this case I think the files may have been lost (The related question mentioned does not have an accepted answer).

However I understand additional help questions should not be asked in an original question so I decided it seems appropriate to ask a separate question.

In my case I had 14.04 installed and tried to upgrade it to 16.04 when prompted to upgrade as a new LTS version was available. The upgrade locked up and left me with an unbootable Ubuntu. (The Lenovo laptop itself would boot as it is triple boot: Ubuntu, Puppy Linux & Windows10) I then installed 16.04 trying to keep the original home partition that took me two install attempts.

The laptop has only the one HDD. I had not even initially realised it had an encrypted Home partition. It has separate partitions for /swap /home and / I now have 16.04 successfully installed and working, and am hoping I may be able to get back the files from my 14.04 install.

If I try encryptfs-unwrap-passphrase I get an error find: ‘/run/user/1000/gvfs’: Permission denied

:~$ sudo ecryptfs-recover-private
[sudo] password for john2: 
INFO: Searching for encrypted private directories (this might take a while)...
find: ‘/run/user/1000/gvfs’: Permission denied

I suspect I have in fact lost any info I may have had. The current user in the new install is "John2" the old install I would have hoped to recover will be "lenub"

/home$ sudo ls -al
total 40
drwxr-xr-x  7 root  root   4096 Oct 30 16:48 .
drwxr-xr-x 25 root  root   4096 Nov  2 09:43 ..
drwxrwxr-x  5 root  root   4096 Oct 30 16:48 .ecryptfs
dr-x------  3 john2 john2  4096 Oct 30 13:31 john
drwx------ 19 john2 john2  4096 Nov  5 16:26 john2
dr-x------  2 john2 john2  4096 Jan  2  2016 lenub
drwx------  2 root  root  16384 Jan  2  2016 lost+found
john2@john2-Lenovo-IdeaPad-N586:/home$ 

Looking at the file listing it is probably not likely I actually have anything that will recover.

Any one able to offer advice on where I can look, or what I can do to either to recover any files I may have, or just confirm nothing was kept and there is no point in looking further.

Annoyingly this coincided with me misplacing a memory stick that had backups on it. Probably another reminder that it is worth keeping multiple backups. (I will at least have older copies of the lost files elsewhere)

1

You probably haven't lost it!! I had this exact problem too, and all I did was unmount the /gvfs directory which for me the command was: umount /run/user/1000/gvfs. I then ran the ecryptfs-recover-private command and it worked. I know how freaked out I was at thinking I had lost my information. I hope this helps someone else.

  • That worked. Not that I understand how or why. – John99 Dec 13 '16 at 0:49
  • Excellent, but the command is: ecryptfs-recover-private – Consumology May 19 '17 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.