0

I bought a bluetooth keyboard (which works perfectly fine on windows) and all the keys are either jumbled or not working at all. It worked fine on ubuntu as well until I pressed the num lock key and ever since then it stopped working. I even tried to reset the keyboard by removing the battery but nothing helps.
The keys that do work are the num pad keys with the fn key, backspace, = (which is mapped under the - key) and the special function keys (such as volume mute/up/down (F10,F11 and F12 respectively), brightness (F5 and F6) etc (all of which are not in accordance with the hardware layout)

Does anyone know how to fix this?
It's a maxxter act-kb-bt-001 keyboard that requires a pin to be typed upon connecting. I can connect with bluetoothctl and it shows me this info but the jumbled keys problem persist.

[Bluetooth 3.0 Keyboard]# info
Device 16:07:02:00:0E:A2
    Name: Bluetooth 3.0 Keyboard
    Alias: Bluetooth 3.0 Keyboard
    Class: 0x002540
    Icon: input-keyboard
    Paired: yes
    Trusted: yes
    Blocked: no
    Connected: yes
    LegacyPairing: yes
    UUID: Service Discovery Serve.. (00001000-0000-1000-8000-00805f9b34fb)
    UUID: Human Interface Device... (00001124-0000-1000-8000-00805f9b34fb)
    UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
    Modalias: usb:v05ACp0239d011B

ps xev and xinput don't register input from any unmapped keys

0

1 Answer 1

1

Default for ubuntu sessions is numlock on.

To make the default numlock off so your keyboard works:

sudo apt-get install numlockx

...then go to Startup Applications Preferences and add a new entry:

enter image description here

1
  • Thanks mate but it was the keyboard. I switched it for another model and it works perfectly now.
    – Akisame
    Commented Apr 28, 2017 at 11:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .