0

Question: Why is the/How to fix language input not changing even after I switch to next text entry source?

What I did: I wanted to install text-entry support for Hangul ibus-hangul (Korean, package also includes Hanja, the Chinese character equivalent for some Korean words) This worked for me before.; Simplified Chinese/Pinyin ibus-sunpinyin, and Traditional Chinese/Pinyin ibus-chewing.

  • Terminal: sudo apt-get install ibus-hangul, sudo apt-get install ibus-sunpinyin, sudo apt-get install ibus-chewing
  • Terminal: sudo reboot, computer reboots
  • Language Support: Add Chinese (simplified), Chinese (traditional), Korean.
  • Text Entry: Add Korean (Hangul) (IBus), Chinese (SunPinyin) (IBus), Chinese (Chewing) (IBus)
  • Terminal: sudo reboot, computer reboots

Anomalies observed:

Please refer to the following figures in this image for reference.

  • Under Hangul entry mode, I don't see the settings for the language for Hangul/Hanja. Figure 1 (Expected) vs. Figure 2 (What is appearing right now)

  • After changing languages, the other language icon appears in the taskbar but I cannot type in desired language.

  • Under Hangul entry mode, if I click Keyboard Layout Chart, the layout chart is for Korean (101/104 key compatible), which was another text-entry mode in Text Entry.

  • Under SunPinyin and Chewing entry modes, if I click Keyboard Layout Chart, the layout chart is for English (US).

  • In Language Support even after installing the languages they appear grayed out. The only language that is in solid black is English and English (US). Figure 3

Thank you! All help is appreciated :)

  • Figure 2 looks buggy (I can't reproduce it). Can you open Text Entry, select Korean (Hangul) (Ibus), and click the tool icon. That should open IBusHangul Setup. Please enable "Start in hangul mode" and check if that makes a difference. – Gunnar Hjalmarsson Nov 5 '16 at 16:55
  • Hi @GunnarHjalmarsson thanks for your comment. Start in Hangul mode has already been checked off; the problem is still there. – user604803 Nov 5 '16 at 16:57
  • You may want to try Fcitx instead. (Figure 3 has nothing to do with this problem. You can click the Help button in Language Support to read about how it works.) – Gunnar Hjalmarsson Nov 5 '16 at 17:58
  • Hi @GunnarHjalmarsson I was considering using Fcitx but I kind of like the iBus layout better, but if this problem is unsolvable then I will go ahead and transition to Fcitx. Thanks! – user604803 Nov 5 '16 at 17:59
  • The problem is probably not unresolvable, but I'm out of ideas. And it works fine for me on Ubuntu 16.10. Which version are you on btw? – Gunnar Hjalmarsson Nov 5 '16 at 18:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.