I hope this has not been covered elsewhere already. It is rather specific an issue, and related to a computer-manufacturer, but I need help for something Ubuntu-related that should be no problem for you guys :)

So, I have this Ideacentre Q150, which seems to be an excellent option for just having a computer at home to surf and to do some editing. However, after installing Ubuntu over Win7, it only takes the Wireless Connection into account, and says there was no cable connected, but there is! And under Win7, the cable was recognized. I have tried this actually on 3 Ideacentres, Win7 works, and both Ubuntu 11.10 don't.

This german website suggests to download 2 packages (http://de.archive.ubuntu.com/ubuntu/pool/main/n/network-manager/network-manager_0.8-0ubuntu3_amd64.deb and http://de.archive.ubuntu.com/ubuntu/pool/main/n/network-manager-applet/network-manager-gnome_0.8-0ubuntu3_amd64.deb) and to

sudo apt-get remove --purge network-manager network-manager-gnome.

But somehow, the dependencies on the two files are not met, and without the network, and as it was a new install, I just reinstalled Ubuntu once more as it just such an easy thing to do.

I have searched through http://packages.ubuntu.com/oneiric/net/ and have found the 2 packages the user suggested, which I assume were more up to date(http://packages.ubuntu.com/oneiric/net/network-manager and http://packages.ubuntu.com/oneiric/net/network-manager-gnome), but for the formats, I am not sure which one would be best and easiest to install... .dsc, .tar.bz2, .tar.gz ? And even then, what to do with the files? I found How do I install tar bz2 and gz files? but I am guessing Softwarecenter would be out of the question?

And lastly! If you know of any other ways that could work, I am all ears! :)

Thanks for any pointers!


##@##:~$ cat /var/lib/NetworkManager/NetworkManager.state
##@##:~$ cat /var/lib/NetworkManager/NetworkManager.state

##@##:~$ lspci -nnk | grep -i net
01:08.0 Ethernet controller [0200]: Intel Corporation 82552 10/100 Network Connection [8086:10fe] (rev 02)
##@##:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 38:60:77:71:b5:89  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 74:2f:68:28:00:a7  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::762f:68ff:fe28:a7/64 Scope:Link
          RX packets:7477 errors:0 dropped:53 overruns:0 frame:0
          TX packets:5336 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6669541 (6.6 MB)  TX bytes:1033545 (1.0 MB)

##@##:~$ dmesg | egrep 'eth0|e100|firm'
[    1.230481] e100: Intel(R) PRO/100 Network Driver, 3.5.24-k2-NAPI
[    1.230490] e100: Copyright(c) 1999-2006 Intel Corporation
[    1.230616] e100 0000:01:08.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[    1.258225] e100 0000:01:08.0: PME# disabled
[    1.259625] e100 0000:01:08.0: eth0: addr 0xfcfff000, irq 20, MAC addr 38:60:77:71:b5:89
[   17.468302] r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
##@##:~$ lsmod | grep e100
e100                   37213  0 
##@##:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

##@##:~$ ping -c 4
PING ( 56(84) bytes of data.
64 bytes from icmp_req=1 ttl=64 time=1.20 ms
64 bytes from icmp_req=2 ttl=64 time=1.20 ms
64 bytes from icmp_req=3 ttl=64 time=1.14 ms
64 bytes from icmp_req=4 ttl=64 time=1.24 ms

--- ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3003ms
rtt min/avg/max/mdev = 1.142/1.197/1.247/0.050 ms


##@##:~$ sudo lshw -c network
[sudo] password for ##: 
  *-network DISABLED      
       description: Ethernet interface
       product: 82552 10/100 Network Connection
       vendor: Intel Corporation
       physical id: 8
       bus info: pci@0000:01:08.0
       logical name: eth0
       version: 02
       serial: 38:60:77:71:b5:89
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=full firmware=N/A latency=64 link=no maxlatency=56 mingnt=8 multicast=yes port=MII speed=100Mbit/s
       resources: irq:20 memory:fcfff000-fcffffff ioport:dc00(size=64)
       description: Wireless interface
       physical id: 1
       bus info: usb@1:1
       logical name: wlan0
       serial: 74:2f:68:28:00:a7
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=r8712u ip= multicast=yes wireless=IEEE 802.11bg
  • have you tried this -> askubuntu.com/questions/55805/… ... is for 10.04 so adapt to your need .. at the end of the page you can see Download network-manager-gnome Architecture there are in deb. format ... – hhlp Dec 2 '11 at 11:56
  • what does your ifconfig -a shows ? network hardware detected ? Please paste the output of sudo lshw -c network. networkmanager is not a critical package that you must have for your network to work its just makes it easy. – sagarchalise Dec 2 '11 at 12:05
  • Also has missing dependencies :-( – bisi Dec 2 '11 at 13:52

The 'german website' had suggested installing packages that were new at the time, but are old now. The same packages in 11.10 are of higher versions then those suggested. That's why you got the 'unmet dependencies' error.

If you still need to download and manually install packages from http://packages.ubuntu.com/, get the .debs instead of tars. There are links for 32 and 64bit debs at the bottom of the network-manager-gnome page.b The deb packages are installable by simple double clicking.

Lastly, if you want to troubleshoot the cable problem, post the outputs of the following, as suggested at the 'german site':

cat /var/lib/NetworkManager/NetworkManager.state
lspci -nnk | grep -i net
ifconfig -a
dmesg | egrep 'eth0|e100|firm'
lsmod | grep e100
cat /etc/network/interfaces
ping -c 4

I don't know any German, but did installing those packages solve the problem for the poster?

  • Thanks Mike! I seem to be a bit slow today, couldn't find the deb download links in packages... but hhlp mentioned a post that had direct links, will try that :). Well, the poster after Praesodym said it did do the trick for him, and as it seemed to exactly fit my issue, I wanted to have a go at it... I have posted the output in the initial Post, and from what little I understand, the Network card is recognized. If I change the cables with the Win7 machine, the Win7 machine works right away, and Ubuntu still stays off. I've tried disabling Wireless and tried switching off DHCP.. – bisi Dec 2 '11 at 13:18
  • I have been very very thick. Clicked on "Show all files" several times, but never clicked in amd64... silly me. So, I did uninstall the two packages, and reinstalled them both, but still no joy... – bisi Dec 2 '11 at 14:13
  • Thanks for the outputs. It looks like everything is in order, you don't seem to have the same symptom as hunon, namely [ 14.475380] ADDRCONF(NETDEV_UP): eth0: link is not ready. Stupid question: was the cable connected when you ran the commands? – mikewhatever Dec 2 '11 at 22:19

There is a ppa for NM and lists some packages. I would try to install all of them blindly, assuming they are all dependencies(hoping they don't depend on something else). Then I would install NM and after my system is running I would autoremove unwanted packages.

Alternatively you can download tarball here and then try to compile it. From there dependency library will keep arising (may be in configure stage?) and you will be installing until it works.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.