0

I want to create various keyboard shortcuts within TeXstudio, but my problem is that the left Alt key takes me out of the text editor and into the File/Edit/View menus (so I can navigate around these menus with the arrow keys). If I press Alt L again, I return to the text editor. How can I disable Alt L from doing this, so that I can use e.g. Alt+a for \alpha, and so on? Thank you.

  • Then you will have the issue of not being able to access the menus. Wouldn't it be better to set your keyboard shortcuts using, for instance, the super key (i.e., the flag key). – Juan Antonio Nov 4 '16 at 12:42
  • Presumably I would still be able to access the menus with the cursor? I only want to disable the Alt L shortcut for the menus. – user307099 Nov 4 '16 at 14:00
  • If I wanted to use the super key instead, how do I disable its default action of bringing up the search menu in the top left? – user307099 Nov 4 '16 at 14:04
  • By not releasing the button. That is, you press the <kbd>SUPER</kbd> key and, while pressed, you press <kbd>A</kbd>. If you press <kbd>SUPER</kbd> and then let go it produces the action you mention. In my case, since I do not have <kbd>SUPER</kbd> + <kbd>A</kbd> assigned, then it is taken as only <kbd>SUPER</kbd> being pressed. Once you assign the shortcut it should work. – Juan Antonio Nov 4 '16 at 14:26
  • I can't even assign such a shortcut because the menu is immediately brought up once I press the super key... – user307099 Nov 4 '16 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy