10

I recently updated my Ubuntu 14.04 installation and upon rebooting I am no longer able to sign into the Ubuntu Desktop environment. I've tried several approaches such as:

  1. renaming .Xauthority and restarting
  2. ensuring that .Xauthority is not owned by root (also ran the command sudo chown -R $USER:$USER $HOME now pretty much all the files in my home directory are executable)
  3. sudo apt-get install ubuntu-desktop and sudo apt-get install --reinstall ubuntu-desktop

Content of .xsession-errors:

Script for ibus started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd main process ended, respawning
init: gnome-session (Unity) main process (6756) terminated with status 1
init: unity-settings-daemon main process (6735) killed by TERM signal
init: Disconnected from notified D-Bus bus
init: logrotate main process (6631) killed by TERM signal
init: xsession-init main process (6726) killed by TERM signal
init: unity-panel-service main process (6760) killed by TERM signal
init: upstart-dbus-session-bridge main process (6675) terminated with status 1
init: hud main process (6740) killed by TERM signal

And are the contents of /var/log/lightdm/lightdm.log

Update

I tried the fix described here and now the Ubuntu Desktop environment is gone. -- and now I have three desktop environments (including gnome) and only xfce works.

Latest Update

I've installed loads of desktop managers(?) as shown below but only two of them work. GNOME Flashback (Metacity) and Xfce session. The rest don't work.

Final Update

Because my many attempt to fix the system made it worse I eventually had to install Ubuntu 16.04 LTS.

enter image description here

2
  • Have you checked logs for login issues?
    – Jacek
    Nov 4 '16 at 10:53
  • What is the output of your lspci -nn | grep '\[03' ? If you have more than one line in that output then your driver probably got affected and you must reinstall it. I have a detailed answer to that in this question The login loop is one of the problems I have faced and installing the Xfce environment did fix it but only temporarily. In short, you should just reinstall the Nvidia driver and then it should work just fine. Any others issues related to that then check the link I've sent.
    – Joe
    Nov 13 '16 at 6:48
2

it looks like you at some point tried to run your xsession as root and this has left some other files owned as root in your home dir.

to list all the files in your home dir owned by root

find ~ -uid 0

have a look at the list and chown anything back to you then try again.

It might also be a good idea to send this to a file for reference later in case you introduce more issues with later changes.

If you are happy that all the files listed by that command should be returned to your ownership then run this command.

find ~ -uid 0 -exec chown $USER:$USER -r {} \;

It would also be worth creating a fresh user account for comparison, try login in with that, if that doesn't work then the issue may not be at user level but could be a system thing.

8
  • I have another account on my machine. I cannot log on to that also. The only files that are owned by root are mostly in my private temp folder.
    – Olumide
    Nov 9 '16 at 18:48
  • so it looks like you have a something broken at the system level so and the fix will most likely involve editing files in /etc/X11
    – Amias
    Nov 9 '16 at 18:55
  • BTW software update wants to update libgbm1 but cannot as the update is blocked. I wonder if this is related to the problem.
    – Olumide
    Nov 9 '16 at 19:05
  • Also the last thing I did before the problem started was to accept an update that included nvidia cuda.
    – Olumide
    Nov 9 '16 at 19:08
  • Update: I did a a force update or or something of the sort and now I can't boot into into any of the desktops. No options are presented.
    – Olumide
    Nov 9 '16 at 20:47
1
  1. Please check and post your /var/log/Xorg.0.log and /var/log/Xorg.0.log.old after the failed login.
  2. Please remove x11-common, remove/rename /etc/X11 and install x11-common again.
  3. XFCE does not use expensive 3D effects, so probably OpenGL and or special graphic drivers are not in place. Check graphic drivers for your card.
4
  • Unfortunately I am no longer in the position to test these steps. I tinkered with my installation until I broke it completely and nothing worked. So I had to reinstall. Now that's not going too smoothly. I almost miss Windows (actually I _am_currently on Windows)
    – Olumide
    Nov 9 '16 at 23:32
  • No doubt, Linux desktop is still the biggest problem, probably the only. Even if upgrading is possible it contains a lot of pitfalls. Usually I separate my home and install a fresh version if nothing else helps.
    – Thomas
    Nov 9 '16 at 23:36
  • say what you will but I miss the relative stability of Windows. I am so scared of upgrading to LTS 16.04. I've been bitten by Ubuntu too many times when I try to do an innocent upgrade and bam the entire installation goes down.
    – Olumide
    Nov 9 '16 at 23:39
  • You won't believe this but after I got my my system up and running and applied a software update same thing thing happened to my ubuntu desktop again!!! Gonna try your your suggestions after all.
    – Olumide
    Nov 10 '16 at 0:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.