0

My problem is this: I can't create a new OpenVPN (or any other type) connection using network manager in an Azure UBUNTU 16.04 LTS virtual machine. The reason is that once I click "create", all options in the editing form appear greyed out (see screenshot) and I can't enter any information in any fiel of any tab.

Editing VPN connection - All greyed out

I am login with the default user created during installation, and use a remote desktop connection from windows to access the UBUNTU VM through an Xfce desktop. I've installed the usual OpenVPN packages and network manager plugins (otherwise the OpenVPN option wouldn't even appear).

I am clueless... can anybody help, please? None of the suggestions in this similar question worked for me...

Thanks in advance!!

EDIT 1: Tried changing permissions for "inactive" sessions in /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy as hinted by @steeldriver, but still having the same problem :-(

Also, I have noticed a weird thing: when I logout from my Remote Desktop Xfce session instead of logging out it takes me to a different Xfce session... with TWO network manager icons in the top right. If I logout again, it finally logsout and closes the Remote Desktop.

  • I think it's normal for NetworkManager actions to be denied to "inactive" (i.e. remote) users by the PolicyKit mechanism - see for example A brief guide to PolicyKit. Does it work if you log in to the XFCE desktop directly on the VM? – steeldriver Nov 4 '16 at 13:03
  • Thanks for the hint, @steeldriver. What do you mean by "log in to the XFCE desktop directly on the VM"? My only options are Remote Desktop or VNC, since it's an Azure VM running in the cloud... – Juan Jesus Nov 10 '16 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.