0

When I changes settings under PCManFM > Edit > Preferences > Volume Management using GUI, it immediately reflects the changes.

But my requirement is to do such thing from command line. So am doing things as follow to disable mount_removable.

sed -i -e 's/mount_removable=1/mount_removable=0/g' /home/user1/.config/pcmanfm/lubuntu/pcmanfm.conf

But It works only after reboot or after I restart the display manager service. I don't wanna do any of this instead I am trying to find a way out such that once I change the pcmanfm.conf file I restart some service (or some process) and it will reflect changes on system and under GUI without rebooting or restarting display manager.

I am stuck here, please help.

2

"Mistakes are the proof that you are trying" - (unknown)

Yes, I made a silly mistake and that too when I knew everything in back off my mind. My colleague pointed out to me and I am like "Oh No!! How did I missed that ??". Anyway.

The solution here is given by following the two steps below.

1) After changing the settings (using sed command) kill the PCManFM process.

killall pcmanfm

2) Restart the PCManFM process.

pcmanfm --desktop --profile lubuntu --display :0 &

Donot forget to restart it as background process (see the & in the above commnad).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.